ARB Solenoid install? - TTORA Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-04-2009, 08:29 PM Thread Starter
Senior Member
chilitoy's Avatar
Join Date: Aug 2008
Location: Eagle
Posts: 239
Angry ARB Solenoid install?

I was trying to get the solenoid on my ARB compressor(new ckma12) and can't quite figure out what I am doing wrong. I have the correct coupler to plumb the solenoid to the compressor. According to the instuctions you loosen a 10 mm bolt and twist the top part(silver tube) of the compressor where there are 2 removable threaded plugs. I can only get the black end cap where the 1/4" pressure switch is to spin. The silver tube needs to spin to get the solenoid threaded in. I tried pretty hard to get it to move( yes, I even put down my purse),but I didn't want to mess anything up. Has anyone had this problem, or I am I just plain ole stupid and can't 'cypher the instructions?

Last edited by chilitoy; 02-05-2009 at 06:16 AM.
chilitoy is offline  
Sponsored Links
post #2 of 4 (permalink) Old 02-04-2009, 10:00 PM
Veteran Member
RedRunnertc's Avatar
Join Date: Dec 2005
Location: Houston, TX
Posts: 15,035
Mine was nice and easy ... is there a 10 mm on each end?

Might just be kinda stuck from the paint on the end caps and need to be snapped loose.

ARB customer service is awesome - if it can wait til tomorrow, I would call them and ask.

Former President - CO Chapter
Founding President - OH Chapter

'93 4Runner lockers, armor, tcases, & stuff

'14 Cadillac CTS VSport

Check out pix at
RedRunnertc is offline  
post #3 of 4 (permalink) Old 02-04-2009, 10:09 PM
Veteran Member
TowerRigger's Avatar
Join Date: May 2007
Location: Wichita, KansAss
Posts: 1,475
Send a message via Yahoo to TowerRigger
I just thought this might be a fun place to use this smiley. Like usual I have nothing of real importance to add.

Is IFS something you can get penicillin for???

Originally Posted by spindleshanks View Post
You flew too close to the sun on wings of whiskey, my friend.
TowerRigger is offline  
post #4 of 4 (permalink) Old 02-05-2009, 08:04 PM Thread Starter
Senior Member
chilitoy's Avatar
Join Date: Aug 2008
Location: Eagle
Posts: 239
Thanx again Troy! I talked with ARB and they explained that the O-rings will stick. After putting my purse and chardonay down, I used a little more leverage and finally got the tank to spin. I also loosend the bolt and went for a bike ride and then tried it when I got home and success. Maybe I was being a little too cautious.Now time to use about a 100 zip ties.
Thanx to you too Towerigger, allsupport helps in times of frustration.
chilitoy is offline  

Quick Reply

Register Now

In order to be able to post messages on the TTORA Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
ADD Solenoid shivs Wanted 0 12-18-2008 07:39 PM
ADD Solenoid Part # shivs Newbie Tech 2 12-13-2008 02:35 PM
Air horns and 12V solenoid Rebuilt98 Off Topic 4 09-14-2007 03:35 PM
ARB solenoid SteveO Early Tacoma Tech 17 02-23-2005 09:16 PM
Starter solenoid bad at 70k, now what? sagexp Early Tacoma Tech 25 02-17-2005 06:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome