Rough idle after a mud bog - TTORA Forum
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 07-31-2007, 06:31 PM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
Rough idle after a mud bog

I like mud bogs a little too much. My 93 would get a rough idle for a little while but then would dry out. My 99 is still idleing rough from 2 weeks ago, I have the 3.4 litre V6. I replaced the air filter, PCV valve is still sucking a good amount of air through, there was no mud in the throttle body but I cleaned the heck out of it anyway. Pardon my frustration but what the hell is going on with my truck. There is an idle speed adjuster underneath the throttle body, do I need to replace that? The Idle drops to about 500 RPM while sitting at a light and the whole truck will shake. But it still runs like a champ at high speed. HELP!

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 07-31-2007, 08:24 PM
Veteran Member
 
fjcruzer's Avatar
 
Join Date: Dec 2006
Location: Denver
Posts: 4,141
Did you clear the tailpipe?

Eric Ross
Denver, CO
07FJC

“Not all who wander are lost…”

http://curtisparkcruiser.weebly.com/

ARB this and that, Warn this and that, OME this and that, Armor this and that, Recovery & Repair this and that...
fjcruzer is offline  
post #3 of 25 (permalink) Old 08-01-2007, 11:18 AM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
Clear the tail pipe? As far as I can tell it doesn't have anything in it. No mud got up in it.

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #4 of 25 (permalink) Old 08-01-2007, 01:28 PM
Veteran Member
 
fjcruzer's Avatar
 
Join Date: Dec 2006
Location: Denver
Posts: 4,141
Hmm, off the top of my head the MAF might be gubered. Perhaps disconnect the battery for 30 seconds and let things reset and see if it makes any diff...

Eric Ross
Denver, CO
07FJC

“Not all who wander are lost…”

http://curtisparkcruiser.weebly.com/

ARB this and that, Warn this and that, OME this and that, Armor this and that, Recovery & Repair this and that...
fjcruzer is offline  
post #5 of 25 (permalink) Old 08-01-2007, 06:57 PM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
I will try that. It seems like somewhat of a common problem with no resolve. Very odd.

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #6 of 25 (permalink) Old 08-01-2007, 07:17 PM
Veteran Member
 
fjcruzer's Avatar
 
Join Date: Dec 2006
Location: Denver
Posts: 4,141
Could be unrelated, might check the fuel filter too... the list goes on.

Eric Ross
Denver, CO
07FJC

“Not all who wander are lost…”

http://curtisparkcruiser.weebly.com/

ARB this and that, Warn this and that, OME this and that, Armor this and that, Recovery & Repair this and that...
fjcruzer is offline  
post #7 of 25 (permalink) Old 08-01-2007, 07:20 PM
Veteran Member
 
TowerRigger's Avatar
 
Join Date: Jun 2007
Location: Wichita, KansAss
Posts: 1,475
Send a message via Yahoo to TowerRigger
Did you actually injest water?

Is IFS something you can get penicillin for???

Quote:
Originally Posted by spindleshanks View Post
You flew too close to the sun on wings of whiskey, my friend.
TowerRigger is offline  
post #8 of 25 (permalink) Old 08-01-2007, 07:32 PM
Veteran Member
 
fjcruzer's Avatar
 
Join Date: Dec 2006
Location: Denver
Posts: 4,141
Quote:
Originally Posted by TowerRigger View Post
Did you actually injest water?
Ahh, good point, might want to Heet the fuel tank and see if any water ingestion burns off...

Eric Ross
Denver, CO
07FJC

“Not all who wander are lost…”

http://curtisparkcruiser.weebly.com/

ARB this and that, Warn this and that, OME this and that, Armor this and that, Recovery & Repair this and that...
fjcruzer is offline  
post #9 of 25 (permalink) Old 08-01-2007, 07:47 PM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
I don't beieve I took in any water. The water only came up to door bottom door height and when I checked the air box nothing made it past the sir filter. I did fill up with gas that day at a station I don't normaly use and I think there might be a possibility of bad gas.

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #10 of 25 (permalink) Old 08-01-2007, 08:28 PM
Veteran Member
 
fjcruzer's Avatar
 
Join Date: Dec 2006
Location: Denver
Posts: 4,141
Hmm, burn it off, put in some high octane and perhaps Heet and burn through another tank and hopefully it'll go away.

Eric Ross
Denver, CO
07FJC

“Not all who wander are lost…”

http://curtisparkcruiser.weebly.com/

ARB this and that, Warn this and that, OME this and that, Armor this and that, Recovery & Repair this and that...
fjcruzer is offline  
post #11 of 25 (permalink) Old 08-01-2007, 08:35 PM
Veteran Member
 
Join Date: Dec 2004
Location: Northglenn, CO
Posts: 4,793
clean your MAF sensor with plastic safe electronic contact cleaner. pull the negative cable and turn the truck on with that disconnected ( clears the whole ECU ) reconnect everything and should run ok for about 200 cycles ( depending on driving about 2 days....) then the ecu will relearn everything and run good from then on

99 Taco with 5 inches of lift and some toys....
12 Jetta TDI that the wife commandeered
03 Silverado tow pig double extra long green edition
tacotoy is offline  
post #12 of 25 (permalink) Old 08-01-2007, 09:24 PM
Veteran Member
 
spindleshanks's Avatar
 
Join Date: Jun 2005
Location: PNW? WTF!
Posts: 2,591
Hijack:
Rich, how come you're not coming to NM?

Quote:
Originally Posted by RedRunnertc View Post
Aren't you a Regional Manager AND a little bitch?
Mr.Clean '03 Taco
As yet unnamed '03 Honda Shadow Sabre 1100
spindleshanks is offline  
post #13 of 25 (permalink) Old 08-02-2007, 01:53 AM
Almost Out of 9 Lives
 
Lysmachia's Avatar
 
Join Date: Sep 2005
Location: Clear Lake City, TX
Posts: 13,296
Send a message via AIM to Lysmachia Send a message via MSN to Lysmachia Send a message via Yahoo to Lysmachia Send a message via Skype™ to Lysmachia
Diagnosing random shizzy like this is such a PITA isn't it? It took Troy and I like 6 different diagnostic tries to figure out why his truck would die at high rpm's over mountain passes. (We finally deduced thanks to thefatkid and blowntaco - that it was probably a bad coil).

It isn't hard to ingest water into the intake of you are mud bashing - even if it only comes up to your doors...

But yeah The MAF trick that Rich (aka Tacotoy) mentions is a good first start.

Oh and you have done the diff breather mod right? Because if you are mud bashing that much without a diff breather you are destroying your diff oil and eventually trashing your gears.

***********
Oh and I second that Hijack Spindle.... I think Rich and Una have spent all their vaca- time getting married We'll miss em though!

Molly
aka Lysmachia
85 4 Runner SAS (Tippy II) - All mashed together in 93runner and 85runner Goodness

Get your 4x4 VIDEO pr0n here
Quote:
Originally Posted by mrdoug View Post
How many people do you think it'd take to hold Molly down while we cut off a limb? I'm guessing alot, plus ratchet straps, c-clamps, and other misc tools
Lysmachia is offline  
post #14 of 25 (permalink) Old 08-02-2007, 07:26 AM
Veteran Member
 
spindleshanks's Avatar
 
Join Date: Jun 2005
Location: PNW? WTF!
Posts: 2,591
oh right.

And Squeetor, you said no water made it past the air filter. But the stock air filter on a Tacoma has a celullose (paper) media, so water can negatively affect it if it comes in contact at all. Maybe if it's waterlogged, your truck can't breathe? Go to CARQUEST and get a new WIX air filter for starters (unless you're running a K&N, in which case you're not interested in filtering incoming air anyway).

Quote:
Originally Posted by RedRunnertc View Post
Aren't you a Regional Manager AND a little bitch?
Mr.Clean '03 Taco
As yet unnamed '03 Honda Shadow Sabre 1100
spindleshanks is offline  
post #15 of 25 (permalink) Old 08-02-2007, 08:41 AM
Veteran Member
 
RedRunnertc's Avatar
 
Join Date: Dec 2005
Location: Houston, TX
Posts: 15,035
Squeetor - just FYI, Spindleshanks is a WIX/Carquest rep...

Former President - CO Chapter
Founding President - OH Chapter

'93 4Runner lockers, armor, tcases, & stuff

'14 Cadillac CTS VSport

Check out pix at www.4wheelingoh.shutterfly.com/action
RedRunnertc is offline  
post #16 of 25 (permalink) Old 08-02-2007, 10:36 AM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
Thumbs up

Hey Tacotoy MAF has been cleaned but haven't disconnected the neg batt cable and turned the key, Fjcruizer suggested that and i will be trying that tonight.

Diff Breather? Not that I go mud bogging all that much but if the opportunity presents itself Looks like a little research is in order. Thanks Lysmachia

Spindle, I checked the stock air filter that had just been put in and it was dry and clean right after our trip which leads me to believe nothing got through. Then it got replaced with a K&N air filter, so brand new filter right now. Doesn't seem like your a big fan of K&N. WIX/Carquest rep huh?! Shameless plug!

Everyone thank you for your help, Your the best group of guy's and gal's a feller could ever meet...over the internet. I have been keeping both eyes on the upcoming trails and looking forward to meeting you all.

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #17 of 25 (permalink) Old 08-02-2007, 04:20 PM
Senior Member
 
Blowntaco's Avatar
 
Join Date: Oct 2005
Posts: 435
Just a thought, Has anyone pulled the spark plugs?????? Might be fouled and still holding water. My
Blowntaco is offline  
post #18 of 25 (permalink) Old 08-02-2007, 08:39 PM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
Yep, checked those. I'm a noob but not that much of a noob. I have been working on bikes, cars and trucks for 10 years, but every vehicle has their quirks. This is my first Tacoma. I have a 93 as well but that is a whole differnt monster! This never happened in it so I figured the all wise and knowing family of COTTORA could shed some light and sure enough there are things that I didn't know like trying to reset the system. Electronics...PHHHHTTTTT!!!

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #19 of 25 (permalink) Old 08-02-2007, 11:18 PM
Veteran Member
 
Join Date: Dec 2004
Location: Northglenn, CO
Posts: 4,793
Quote:
Originally Posted by spindleshanks View Post
Hijack:
Rich, how come you're not coming to NM?
wasn't planning on going in the first place.... i dont like the ginormous wheeling adventures really... not quite my style

99 Taco with 5 inches of lift and some toys....
12 Jetta TDI that the wife commandeered
03 Silverado tow pig double extra long green edition
tacotoy is offline  
post #20 of 25 (permalink) Old 08-02-2007, 11:23 PM
Veteran Member
 
Join Date: Dec 2004
Location: Northglenn, CO
Posts: 4,793
Quote:
Originally Posted by Squeetor View Post
Hey Tacotoy MAF has been cleaned but haven't disconnected the neg batt cable and turned the key, Fjcruizer suggested that and i will be trying that tonight.

Diff Breather? Not that I go mud bogging all that much but if the opportunity presents itself Looks like a little research is in order. Thanks Lysmachia

Spindle, I checked the stock air filter that had just been put in and it was dry and clean right after our trip which leads me to believe nothing got through. Then it got replaced with a K&N air filter, so brand new filter right now. Doesn't seem like your a big fan of K&N. WIX/Carquest rep huh?! Shameless plug!

Everyone thank you for your help, Your the best group of guy's and gal's a feller could ever meet...over the internet. I have been keeping both eyes on the upcoming trails and looking forward to meeting you all.

if the problem comes up after flashing the ecu then try going to autozone and see if they will pull up the realtime diag stuff for you and see what your maf reads and your egt reads.

99 Taco with 5 inches of lift and some toys....
12 Jetta TDI that the wife commandeered
03 Silverado tow pig double extra long green edition
tacotoy is offline  
post #21 of 25 (permalink) Old 08-03-2007, 02:57 PM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
So far the problem has smoothed out, but I haven't sat at idle long enough to really check. Thanks for the idea's tacotoy.

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #22 of 25 (permalink) Old 08-03-2007, 08:06 PM
Veteran Member
 
Join Date: Dec 2004
Location: Northglenn, CO
Posts: 4,793
thats what im here for. another thing to try and do is take your truck on a long drive on a hot day... get the truck all hot and try to evaporate any mystery water that you might have

99 Taco with 5 inches of lift and some toys....
12 Jetta TDI that the wife commandeered
03 Silverado tow pig double extra long green edition
tacotoy is offline  
post #23 of 25 (permalink) Old 08-05-2007, 09:17 PM
Almost Out of 9 Lives
 
Lysmachia's Avatar
 
Join Date: Sep 2005
Location: Clear Lake City, TX
Posts: 13,296
Send a message via AIM to Lysmachia Send a message via MSN to Lysmachia Send a message via Yahoo to Lysmachia Send a message via Skype™ to Lysmachia
LOL yeah get your truck all hot and bothered!

Molly
aka Lysmachia
85 4 Runner SAS (Tippy II) - All mashed together in 93runner and 85runner Goodness

Get your 4x4 VIDEO pr0n here
Quote:
Originally Posted by mrdoug View Post
How many people do you think it'd take to hold Molly down while we cut off a limb? I'm guessing alot, plus ratchet straps, c-clamps, and other misc tools
Lysmachia is offline  
post #24 of 25 (permalink) Old 08-07-2007, 06:02 PM Thread Starter
Senior Member
 
Squeetor's Avatar
 
Join Date: Jul 2007
Location: Denver, Colorado
Posts: 111
Me get the truck all hot and bothered OR the truck geting me all hot and bothered that is the true question!

Update, Cleaned the throttle intake, replaced the PCV valve, replaced the Air filter with a K&N, new plugs NGK, flashed the ecu and still have a problem with the idle dipping down to the 500 rpm mark. Any other ideas? got to admit, the guy I bought this truck from was a maintenance genius! Like not doing a damn thing. Replaced the transmission oil...Black as night and about a half a quart shy. Bosch plugs in it (better suited for German cars) the passenger side closest to the cab plug cylinoid wasn't even bolted in!!! The poor Baby!!! I'll try flashing the ECU again and see what transpires.

1999 Tacoma TRD
3" Fabtech lift
33"x12.5" Good Year Wrangler DuoTrac.

Squeetor the Arch nemesis of Skelator!!!
Squeetor is offline  
post #25 of 25 (permalink) Old 08-07-2007, 08:04 PM
Veteran Member
 
Join Date: Dec 2004
Location: Northglenn, CO
Posts: 4,793
if i remember right there is an idle air control valve somewhere in the intake.... could be the problem there.... ive never looked for it though

99 Taco with 5 inches of lift and some toys....
12 Jetta TDI that the wife commandeered
03 Silverado tow pig double extra long green edition
tacotoy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TTORA Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle HFD67 Early Tacoma Tech 8 06-01-2007 03:04 PM
No power and rough idle cevinklark Early Tacoma Tech 10 04-07-2007 08:42 PM
Rough idle blk98tacoma Performance/Engine/Exhaust 1 01-07-2007 03:38 PM
Rough Idle.... TruckinT Pickup/Early 4Runner Tech 30 07-31-2006 01:07 AM
Rough Idle? Blone Performance/Engine/Exhaust 7 05-01-2005 10:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome