1989 pickup 22r (MAF issue?) - TTORA Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-17-2011, 09:25 PM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 29
1989 pickup 22r (MAF issue?)

hi,

its been awhile the last time i was here. i used to own a 98 tacoma and got a lot of great help from you guys !

now i own an older pickup...its a 89 pickup hard body with the 22r engine. heres my problem and i hope you guys can help me out. i just bought it yesterday and today I messed up. i was changing the spark plugs (put some bosch platinum), then i removed the air filter to clean it, and heres where I messed up....i removed the two screws from the MAF connector and attempted to unplug the hardness from the MAF. i did this to try to take apart the sensor and clean it with some alky and q-tips. well i couldnt really take it out so i put everything back the same way and now the engine wont start. it just cranks.

did i mess something up badly? did i break it?

sinful is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-17-2011, 09:32 PM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 29
i just read somewhere that is possible the MAF inside door may have stuck closed or open. i really hope thats the problem. ill check tomorrow. in the meantime any other thoughts..plz share.

thanks

btw i did all this because there some light bucking and rocking under light acceleration. it goes away with more gas but def is not normal. it also want to stall with the AC on. also im suspecting bad mpg. the new plugs did not make a difference. but again it seems the truck needs some work. old spark plugs, old cap/rotor, etc etc. needs minor work
sinful is offline  
post #3 of 8 (permalink) Old 10-17-2011, 10:28 PM
Senior Member
 
mosk22rte's Avatar
 
Join Date: May 2010
Posts: 472
If you never got the connector out of the AFM body it's unlikely you damaged it. That connector is held in with silicone, and needs to be sliced free with a razor or Exacto. It's hard to be 100% sure without seeing it, but in my experience 22RE AFMs are actually pretty forgiving. This is assuming that all you did was try to remove the electrical connector. If you loosened the flat wound spring without noting its position first, moved the position of the armature relative to the shaft it attaches to, well, you could be pretty screwed. But you didn't say you did those things, so as long as you didn't you should be OK.

Let me ask a different question: is this a manual trans truck? If it is, are you attempting to start it without depressing the clutch pedal? 'Cause...that would be your problem if that were the case. Just a thought, as I've seen people new to these trucks pull their hair out trying to figure that one out. And if that isn't the case, well, give us some more details about what you did and what it does when you turn the key...

2002 Tacoma DC V6 PreRunner (converted to 5 speed and 4x4, with some other stuff, too)
1986 turbo 4x4 pickup (my money pit)
-
Converting an early Taco from auto to manual?
My PDF of first gen. Tacoma ECU pinout comparisons will help!

Last edited by mosk22rte; 10-18-2011 at 12:26 PM.
mosk22rte is offline  
post #4 of 8 (permalink) Old 10-18-2011, 11:33 AM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 29
let me clarify....

i removed the two philip screws from the connector to the MAF assembly. i gently tried to pull it and half way I noticed there was some other connected attached and looked complicated. so i pushed it back and tightened the screws......attempted to start the engine......nothing. it just turns over but it wont fire up.

sinful is offline  
post #5 of 8 (permalink) Old 10-18-2011, 11:46 AM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 29
you know how in some MAF units the sensor itself can be removed from the assembly...and once is out you can easily clean the tin small wire off the sensor? i attemped to do that but didnt get that far. i basically left the maf connection plugged, didnt touch anyrthing, instead i jumped into removing the screws first, once they were loose, i attempted to remove everything at once.

but im going to double check right now. i wanted to do this first thing this morning but im a lil sick.
sinful is offline  
post #6 of 8 (permalink) Old 10-18-2011, 12:33 PM
Senior Member
 
mosk22rte's Avatar
 
Join Date: May 2010
Posts: 472
OK, just to be clear: if this is from a 1989 22RE, this is an air flow meter (AFM), not a mass air flow sensor (MAF). They work very differently.

1985-1995 Toyota trucks with 22RE and 22RTE motors, aka "pre-Tacoma trucks", have an AFM. (the 1984-88 trucks used a different AFM than the 89-95 ones, but we'll skip over that for now...)

1989-1995 22RE AFM:



Tacomas with 3RZ or 5VZE motors have a MAF.

MAF:


Maybe post a picture so we can be sure we are talking about the same piece of equipment, OK?

Jeff

2002 Tacoma DC V6 PreRunner (converted to 5 speed and 4x4, with some other stuff, too)
1986 turbo 4x4 pickup (my money pit)
-
Converting an early Taco from auto to manual?
My PDF of first gen. Tacoma ECU pinout comparisons will help!
mosk22rte is offline  
post #7 of 8 (permalink) Old 10-18-2011, 08:35 PM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 29
sorry yes its an air flow meter. the picture above.

i discovered the problem. my dumb self broke some solder connections inside the meter when i removed the two screws and pulled the piece out. i was lucky enough though, we managed to solder it back together and now the truck is running.



advise. never loosen those two screws.
sinful is offline  
post #8 of 8 (permalink) Old 10-18-2011, 10:24 PM
Senior Member
 
mosk22rte's Avatar
 
Join Date: May 2010
Posts: 472
Quote:
Originally Posted by sinful View Post
we managed to solder it back together and now the truck is running.
Well, that's the important part. Glad you got it sorted out.

Jeff

2002 Tacoma DC V6 PreRunner (converted to 5 speed and 4x4, with some other stuff, too)
1986 turbo 4x4 pickup (my money pit)
-
Converting an early Taco from auto to manual?
My PDF of first gen. Tacoma ECU pinout comparisons will help!
mosk22rte is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TTORA Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 SAS Pickup w/ 3.4 v6 Killer Red Taco Vehicles/Trailers 8 05-03-2010 03:27 PM
1989 Pickup SAS and Bed Bob extremetoy2000 Solid Axle Swap Tech 12 12-09-2007 11:10 AM
1989 Toyota pickup V6 SAS XSR5X Vehicles/Trailers 6 10-19-2007 04:03 PM
Fuel System Issue - 1989 4Runner 4x4 HKforte Pickup/Early 4Runner Tech 2 01-18-2007 06:56 AM
1989 Toyota pickup F/S Crash For Sale/WTB in AZ 0 07-06-2006 03:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome