Phils 2005 4runner SAC - Page 6 - TTORA Forum
Reply
 
LinkBack Thread Tools Display Modes
post #151 of 177 (permalink) Old 05-14-2011, 11:24 PM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305
Quote:
Originally Posted by jester_motorsports View Post
In regards to the fluid discussion, when I called the guys at PSC to ask them about what fluid to run, they told me that they run regular old clear power steering fluid from O'Reilly Auto parts in all of their stuff. They just said that as long as it's a true, clear power steering fluid that it would be just fine. They used to recommend Royal Purple but they found the cheap stuff worked just fine.
Well like I said earlier.... they seem to give conflicting information. They said Royal Purple only. So thats what I chose. To be honest, its not that crazy expensive... I think it was like 25 or 30 bucks to fill the system.... Box, cooler, pump, lines, resi, and ram. Lots of things to fill.

2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
Sponsored Links
Advertisement
 
post #152 of 177 (permalink) Old 05-15-2011, 03:40 PM
Machinist Extraordinare
 
jester_motorsports's Avatar
 
Join Date: Apr 2005
Location: Edwardsville, IL
Posts: 2,161
Quote:
Originally Posted by medic83 View Post
Well like I said earlier.... they seem to give conflicting information. They said Royal Purple only. So thats what I chose. To be honest, its not that crazy expensive... I think it was like 25 or 30 bucks to fill the system.... Box, cooler, pump, lines, resi, and ram. Lots of things to fill.
Very conflicting. In some of their printed literature it actually said to use Royal Purple. Then you get them on the phone and ask and they tell you otherwise. Hopefully there's no issues and we don't have to worry about it.

Josh
99 Tacoma
jester_motorsports is offline  
post #153 of 177 (permalink) Old 05-15-2011, 10:34 PM
Member
 
sgirt's Avatar
 
Join Date: Dec 2004
Posts: 92
Beautiful build! It really came out nice. I have a few questions about the sensors. Did you have to put in any speed sensors in the front axle for the DAC or ABS.

1969 Toyota FJ40. FJ80 Axles, Chevy 5.3, Dodge NV4500HD. Full restore with enhancements. My Web page
sgirt is offline  
post #154 of 177 (permalink) Old 05-16-2011, 01:09 AM
Veteran Member
 
AZ98TRD's Avatar
 
Join Date: Aug 2010
Location: Phoenix, Az
Posts: 673
Just read this entire build. Makes me want to sell my Taco and get a runner!

1998 Tacoma TRD AWD. Lexus 4.7L 2UZ-FE. Lexus A750F 5 Speed Auto. SOLD...

2006 4Runner SR5 4WD. 4.0L V6 1GR-FE. 5 Spd Auto A750F. Bilstein 5100 w/ OME 884 (FRT). Bilstein 5100 w/ OME 895E (REAR). 285/70/17 Nitto Terra Grapplers. BOVADS roof rack. Unitrol Siren w/ Code 3 100w speaker.
AZ98TRD is offline  
post #155 of 177 (permalink) Old 05-17-2011, 09:29 AM
Veteran Member
 
Stoffregen Motorsports's Avatar
 
Join Date: Aug 2010
Location: Cool, CA
Posts: 519
Quote:
Originally Posted by medic83 View Post
Well like I said earlier.... they seem to give conflicting information. They said Royal Purple only. So thats what I chose. To be honest, its not that crazy expensive... I think it was like 25 or 30 bucks to fill the system.... Box, cooler, pump, lines, resi, and ram. Lots of things to fill.
My frustration stems not from the theory that we need to run synthetic fluid, but that so many people point to "the wrong fluid" when there is the slightest bit of problem. I stand by my suspicion that, as Jester reminded me, "clear fluid" should work just fine. If you are having cavitation, heating problems, then there simply is another problem.
Stoffregen Motorsports is offline  
post #156 of 177 (permalink) Old 05-17-2011, 09:30 AM
Veteran Member
 
Stoffregen Motorsports's Avatar
 
Join Date: Aug 2010
Location: Cool, CA
Posts: 519
Quote:
Originally Posted by Stoffregen Motorsports View Post
My frustration stems not from the theory that we need to run synthetic fluid, but that so many people point to "the wrong fluid" when there is the slightest bit of problem. I stand by my suspicion that, as Jester reminded me, "clear fluid" should work just fine. If you are having cavitation, heating problems, then there simply is another problem.
I guess I could have gotten to the point. When companies like PSC tell us many different things, it makes my job A LOT HARDER!!!
Stoffregen Motorsports is offline  
post #157 of 177 (permalink) Old 03-07-2012, 12:22 AM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305





2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #158 of 177 (permalink) Old 03-07-2012, 10:58 PM
Veteran Member
 
Son of Mayhem's Avatar
 
Join Date: Oct 2005
Location: colorado springs
Posts: 2,786
Nice runner!

Beautiful dogs!

2007 Toyota Super Taco
Son of Mayhem is offline  
post #159 of 177 (permalink) Old 04-04-2012, 11:20 PM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305
Quote:
Originally Posted by Son of Mayhem View Post
Nice runner!

Beautiful dogs!
Thanks!

2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #160 of 177 (permalink) Old 04-07-2012, 08:45 AM
Veteran Member
 
awsumdc's Avatar
 
Join Date: Dec 2004
Location: SoCal, O.C.
Posts: 2,813
Quote:
Originally Posted by Stoffregen Motorsports View Post
I guess I could have gotten to the point. When companies like PSC tell us many different things, it makes my job A LOT HARDER!!!
Here is what happened and why people get conflicting reports.

At first PSC said to use Royal Purple for their systems. Printed it that way and thats what most of us did. Then after some time, someone found out that the clear fluid would work just fine, so because it is just a bit cheaper, PSC said it's fine to use it but did not change any of their printed stuff about using Royal Purple. Thats all.

Stuff out on the internet has been there since day one and when someone runs across it they take it as gospel. It's just that simple.

When people ask me about it, I tell them I run Royal Purple but the clear will work just fine. At that point the conversation is over.

'05 "SAC" Double Cab TRD Sport 4x4 with Marlin Crawler "Taco" Box and a bunch of other stuff.
Linked, Locked & Large!
"THE BEAST"

AKA "THE BIG SEXY"
Wyatt Scott

3.4 auto crawler install

Installing an FJ Case into an 05+ Tacoma

My Build thread. Building "The Beast"

GOT SAC?
awsumdc is offline  
post #161 of 177 (permalink) Old 04-11-2012, 12:39 PM
Veteran Member
 
Stoffregen Motorsports's Avatar
 
Join Date: Aug 2010
Location: Cool, CA
Posts: 519
Quote:
Originally Posted by awsumdc View Post
Here is what happened and why people get conflicting reports.

At first PSC said to use Royal Purple for their systems. Printed it that way and thats what most of us did. Then after some time, someone found out that the clear fluid would work just fine, so because it is just a bit cheaper, PSC said it's fine to use it but did not change any of their printed stuff about using Royal Purple. Thats all.

Stuff out on the internet has been there since day one and when someone runs across it they take it as gospel. It's just that simple.

When people ask me about it, I tell them I run Royal Purple but the clear will work just fine. At that point the conversation is over.
Agreed. Thank you for backing me up!

Sometimes the internet sucks...
Stoffregen Motorsports is offline  
post #162 of 177 (permalink) Old 04-12-2012, 09:01 PM
#1 cruiser
 
orange crusher's Avatar
 
Join Date: Apr 2007
Location: Colorado area
Posts: 3,660
I want the house and the runner!

Felix is my Hero!
orange crusher is offline  
post #163 of 177 (permalink) Old 04-16-2012, 09:06 PM
Veteran Member
 
Stoffregen Motorsports's Avatar
 
Join Date: Aug 2010
Location: Cool, CA
Posts: 519
Hey Phil, how's that tire carrier working out? Does it still shake like the old one?
Stoffregen Motorsports is offline  
post #164 of 177 (permalink) Old 04-20-2012, 01:56 PM
Veteran Member
 
Wolfe's Avatar
 
Join Date: Apr 2009
Location: NorCal
Posts: 766
Love this 4Runner. How did you guys mount the shrockworks bumper after the conversion. Did you have to hack up the stock brackets or did you fabricate new ones. I'm looking to mount my shrockworks bumper on my Tacoma so my bumper brackets are different than yours but I'm just looking for ideas. Pretty sure mine are going to have to be welded but in this picture it looks like you were still able to bolt the brackets on?

Quote:
Originally Posted by medic83 View Post
Sorry for the Big Ass pics


'04 Double Cab

TTORA NorCal Chapter
Wolfe is offline  
post #165 of 177 (permalink) Old 04-20-2012, 05:29 PM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305
Quote:
Originally Posted by Stoffregen Motorsports View Post
Hey Phil, how's that tire carrier working out? Does it still shake like the old one?
Still shakes. Im cutting the whole bumper off and building a new one this summer. I just hope I do it before it breaks off again!!! Lets hit the con this summer.

2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #166 of 177 (permalink) Old 04-22-2012, 11:23 PM
Veteran Member
 
Stoffregen Motorsports's Avatar
 
Join Date: Aug 2010
Location: Cool, CA
Posts: 519
Quote:
Originally Posted by medic83 View Post
Still shakes. Im cutting the whole bumper off and building a new one this summer. I just hope I do it before it breaks off again!!! Lets hit the con this summer.
Yeah, that bumper need some more reinforcing.

I'm game. Now that I finally have a nice tow rig.
Stoffregen Motorsports is offline  
post #167 of 177 (permalink) Old 05-13-2012, 11:54 AM
rai
Member
 
rai's Avatar
 
Join Date: Oct 2005
Location: AR
Posts: 32
What size wheels and tires are those toyos? 37 and 17?
rai is offline  
post #168 of 177 (permalink) Old 05-13-2012, 12:48 PM
Veteran Member
 
Wolfe's Avatar
 
Join Date: Apr 2009
Location: NorCal
Posts: 766
Quote:
Originally Posted by rai View Post
What size wheels and tires are those toyos? 37 and 17?
Yep

Quote:
Originally Posted by medic83 View Post
37/12.5/17 Does great...its my DD. If you want brand new 37's...Im sellin em 5 tires. I want 38's

'04 Double Cab

TTORA NorCal Chapter
Wolfe is offline  
post #169 of 177 (permalink) Old 05-17-2012, 01:17 PM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305
Quote:
Originally Posted by rai View Post
What size wheels and tires are those toyos? 37 and 17?
Quote:
Originally Posted by bdw0lfe View Post
Yep
Had BFG 37x12.5x17s now Im running 37x13.5x17s ( measure 14.5" wide tho... they are pigs) Im going with the kevlar 38's next I think.

2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #170 of 177 (permalink) Old 06-22-2012, 02:04 AM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305




Pismo








2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #171 of 177 (permalink) Old 06-22-2012, 02:05 AM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305






2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #172 of 177 (permalink) Old 06-22-2012, 12:08 PM
Senior Member
 
Join Date: Feb 2009
Location: Orange County, CA
Posts: 157
The Articulation on this thing is disgusting. you sir have built my dream beast, minus the fact that its not the V8.

Awesome job, and I hate you with jealousy!

2011 Tacoma Pre-runner DBL Cab.- Lots to come!
anthonytacoma is offline  
post #173 of 177 (permalink) Old 06-23-2012, 02:30 AM Thread Starter
Senior Member
 
medic83's Avatar
 
Join Date: Mar 2009
Posts: 305
Quote:
Originally Posted by anthonytacoma View Post
The Articulation on this thing is disgusting. you sir have built my dream beast, minus the fact that its not the V8.

Awesome job, and I hate you with jealousy!
The v8 is gutless for a v8 IMO. The 4.0 v6 has more HP. Im gonna put the trd blower on it anyway. But thanks for your compliments.

2005 4runner SE SAC....37's...ARB's...4.88's
medic83 is offline  
post #174 of 177 (permalink) Old 07-24-2012, 10:36 AM
Veteran Member
 
Stoffregen Motorsports's Avatar
 
Join Date: Aug 2010
Location: Cool, CA
Posts: 519
Nice trailer Phil.
Stoffregen Motorsports is offline  
post #175 of 177 (permalink) Old 07-24-2012, 12:37 PM
Veteran Member
 
lrgrnr's Avatar
 
Join Date: Apr 2010
Location: Asheboro NC
Posts: 1,288
lol....isn't this your runner?




Seen it on Facebook..
lrgrnr is offline  
post #176 of 177 (permalink) Old 09-03-2012, 06:54 PM
Veteran Member
 
Supra TT's Avatar
 
Join Date: Sep 2009
Location: Amboy, IL
Posts: 572
Quote:
Originally Posted by Stoffregen Motorsports View Post
My frustration stems not from the theory that we need to run synthetic fluid, but that so many people point to "the wrong fluid" when there is the slightest bit of problem. I stand by my suspicion that, as Jester reminded me, "clear fluid" should work just fine. If you are having cavitation, heating problems, then there simply is another problem.
Not to thread jack your shit Medic, but since it is still part of a discussion in your thread I figured I'd add to it

I recently installed my full hydro with a double ended ram on my D44 (Laugh all you want ) And decided to run Amsoil tractor hydraulic/transmission oil in the system. I am running a 12" heatsink with the system for cooling.



Bleeding the system took 25 minutes tops. Worked excellent when I tried it after it was bled.

After wheeling it this weekend for 3 days straight I was EXTREMELY impressed with the full hydro. I absolutely love it! (Ball joints don't ) It did get warm, when I touched the heatsink after a very difficult trail it was hot to the touch, but the fluid never boiled over. I am thinking maybe a 24" cooler instead of the 12". Maybe the 12" works fine, I am not too sure how hot it should get.




2000 Taco Ext. Cab 2.7L, SAS D44 3 Link front and Ford 9" Full widths. Never ending cycle...
SAS Gathering
SAS Build Thread
Supra TT is offline  
post #177 of 177 (permalink) Old 10-26-2012, 06:48 PM
Newbie
 
kudzucrawler's Avatar
 
Join Date: Sep 2009
Location: Greenville, SC
Posts: 4
Awesome build (and a real clean one at that) and props for getting out and wheeling it too. I've wanted to do the same style 3 link set up for my front. Time and money and I ain't got either, someday.
kudzucrawler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TTORA Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 vs. 2005 4runner V8 12guns Late 4Runner Tech 4 01-14-2010 01:21 AM
WTB 8" 3.73 R&P for 2005 4Runner Teotwaki Parts/Electronics/Wheels/Tires 9 02-02-2009 09:22 PM
WTB 8" 3.73 R&P for 2005 4Runner Teotwaki Wanted 0 10-02-2008 09:23 AM
4Runner Wheels 2006/2005 Xterrable Wanted 0 03-28-2006 07:02 AM
2005 4Runner (HAC) BigDaddyToy Pickup/Early 4Runner Tech 14 01-07-2006 09:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome