Engine trouble code: P0450 Evap Pressure Sensor - TTORA Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-02-2006, 08:36 PM Thread Starter
Member
 
Join Date: Sep 2006
Location: Las Vegas, NV
Posts: 47
Engine trouble code: P0450 Evap Pressure Sensor

Well I've got a small issue here and was hoping I could get some insight. Lately, I've been getting a CEL that reads P0450, which is an Evap Pressure Sensor malfunction. Now, it is VERY intermittent, it usually takes one to three weeks before it starts to come back on after I pull the battery cable to reset the code. From searching, I found that it could possibly be a leak in the fuel lines, but if it was a leak wouldnt the CEL come on consistently? I'm assuming that the Evap Pressure Sensor is going bad, thus being the reason for the CEL coming on at intermittent stages. Before I go dish out $157 on a new Pressure sensor, does anyone else know what might cause this trouble code to be thrown out?

2000 TRD Tacoma Prerunner (SOLD 8/24/07)

2005 Double Cab TRD Tacoma Prerunner
ochatesme is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-02-2006, 10:06 PM
THAT guy.
 
SAR_Squid79's Avatar
 
Join Date: Apr 2005
Location: San Diego, CA
Posts: 5,490
Send a message via Yahoo to SAR_Squid79
If you're not screwing your gas cap all the way on until it clicks, you can get that CEL code.

~Jamie
2000 Tacoma TRD 4WD PreRunner
Supercharged. Locked. Armored.


Mountain: She can crawl it.
Ass: She can haul it.


"Roads? Where we're going we don't need . . . roads."
~Dr. Emmett L. Brown

My Rig My Trailer 4xInnovations
SAR_Squid79 is offline  
post #3 of 6 (permalink) Old 12-02-2006, 10:08 PM Thread Starter
Member
 
Join Date: Sep 2006
Location: Las Vegas, NV
Posts: 47
Quote:
Originally Posted by SAR_Squid79
If you're not screwing your gas cap all the way on until it clicks, you can get that CEL code.
Read about this one too, I make sure the gas cap clicks several times after I gas up. It still clicks even after the CEL comes on so i'm assuming, hopefully, that it's not the gas cap.

2000 TRD Tacoma Prerunner (SOLD 8/24/07)

2005 Double Cab TRD Tacoma Prerunner
ochatesme is offline  
post #4 of 6 (permalink) Old 12-03-2006, 01:26 AM
Veteran Member
 
RaideRNatioN's Avatar
 
Join Date: Dec 2004
Posts: 1,034
Send a message via AIM to RaideRNatioN
check all your vaccum lines off of the manifold?

100% AMERICAN

Keep working. Millions on welfare depend on you!
RaideRNatioN is offline  
post #5 of 6 (permalink) Old 12-09-2006, 12:11 PM Thread Starter
Member
 
Join Date: Sep 2006
Location: Las Vegas, NV
Posts: 47
Little update on this, I went ahead and ordered a new evap pressure sensor from www.toyotaworld.com seeing as how the dealer wanted about $190 for it. My CEL came on again two days ago and instead of clearing the code like I usually I decided to ride it out and see if it goes away on its on. Well, it went away last night while I was at blockbuster, anyone know why the CEL would have cleared itself? I'm sure it'll come back on within a week or so.

2000 TRD Tacoma Prerunner (SOLD 8/24/07)

2005 Double Cab TRD Tacoma Prerunner
ochatesme is offline  
post #6 of 6 (permalink) Old 12-21-2006, 09:09 PM Thread Starter
Member
 
Join Date: Sep 2006
Location: Las Vegas, NV
Posts: 47
Final update for this thread. My new Evap Pressure Sensor came in last week and I've gone through about 3 tanks of gas without a CEL light. Hope this solves my issue.

2000 TRD Tacoma Prerunner (SOLD 8/24/07)

2005 Double Cab TRD Tacoma Prerunner
ochatesme is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TTORA Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
p1300 check engine code sjvicker Performance/Engine/Exhaust 1 01-15-2006 05:10 PM
Check Engine error code? P0420 EVOM1 Performance/Engine/Exhaust 8 07-11-2005 11:26 AM
Check engine code TJGRCD Early Tacoma Tech 6 12-28-2004 08:43 PM
"fuel trim malfunction (bank 1)" trouble code BradleyD Performance/Engine/Exhaust 12 12-19-2004 09:33 AM
Exhaust Trouble Code P0420 and Cat-Back Conflict? Beave Performance/Engine/Exhaust 5 12-18-2004 03:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome