: AC "Vent" Selector Problems


TACORICAN
06-20-2005, 04:02 PM
I am not sure what this is called but the know where you can select where you want AC comming out of. Not the one that sets the temp. This thing is not working.... Air will not come out of the two front vent right in the center of the Dash. If I select that it will give air on the floor and the sides. Sometimes I switch the windshield and back and it will work and sometimes it doesn't Only a little bit of air comes out trhu the middle. This happened right after going to Pismo. But like I said when i play with it, air does come out as normal thru those Vents in the middle. What could be the problem?

01taco4x4
06-20-2005, 04:08 PM
I am having the same problem with mine. What year model is yours. Is this happening to anyone else?

TACORICAN
06-20-2005, 04:19 PM
Its a 2002 Xtra Cab V6

01taco4x4
06-20-2005, 04:41 PM
mines an 01, next time im near the dealer i might stop in and ask some questions or have it looked at.

TACORICAN
06-20-2005, 05:40 PM
22 views. No one has this problem?

TRD SyRuP
06-20-2005, 05:42 PM
mine has the same problem..04 ext cab prerunner..its at the dealer getting its 30k..and theyre looking at the problem..ill let you all know what was wrong when i get it back tonight

TACORICAN
06-20-2005, 06:02 PM
Keep us posted man.
Thanks

Eztrog88
06-20-2005, 06:48 PM
1998 Reg Cab 4x4 here, 2.7L 5-speed. Had it a year now, my center vents never work unless a half close both the side vents; defrost is week unless I close the side vents; and I get air out of the side vents when it's switched (on the dash) to floor. I think it's just the way the ducting is set-up.

thehulk
06-20-2005, 06:56 PM
I think (don't quote me...) the newer models use an electric motor to move the vanes in the vents...the older models use cables. Maybe the electric motor is bad? Just a guess though...

Good luck!

TRD SyRuP
06-20-2005, 08:16 PM
well..got my truck back..and the A/C comes out of the selected vents...but they had to order me a heating unit covered under warrenty..

they said they took it apart..and a plastic piece behind the selector knob was broken..so they had one in stock..NO CHARGE..and now it works..

Driftaco
06-21-2005, 12:30 AM
well..got my truck back..and the A/C comes out of the selected vents...but they had to order me a heating unit covered under warrenty..

they said they took it apart..and a plastic piece behind the selector knob was broken..so they had one in stock..NO CHARGE..and now it works..
when u say it works do u mean that the air flow is the SAME from the 2 center vents as it is from the 2 side vents??? :eek:

my truck has never had equal flow from the center vents unless I close the side vents halfway like someone else sayed. i have always assumed t was due to the design of the ducting or something. this is one of the only things that buggs me aout my truck and if I can realy fix it by buying some falking plastic peace that would be the shit!

TRD SyRuP
06-21-2005, 02:53 AM
when u say it works do u mean that the air flow is the SAME from the 2 center vents as it is from the 2 side vents??? :eek:

my truck has never had equal flow from the center vents unless I close the side vents halfway like someone else sayed. i have always assumed t was due to the design of the ducting or something. this is one of the only things that buggs me aout my truck and if I can realy fix it by buying some falking plastic peace that would be the shit!

yeah..as in..all 4 vents blow air now..lol..equal..who cares..i get air now..

pmh203
06-21-2005, 09:53 AM
I have an 04 v6 ext cab and my center ones dont work at all. when I changed out my head unit last week it looks like the vents don't even match up with the ducting ?

TACORICAN
06-21-2005, 04:41 PM
well..got my truck back..and the A/C comes out of the selected vents...but they had to order me a heating unit covered under warrenty..

they said they took it apart..and a plastic piece behind the selector knob was broken..so they had one in stock..NO CHARGE..and now it works..
So what was the problem? The Heating Unit or the Selector Knob?

MattyFatty182
06-21-2005, 04:45 PM
Mine does the same thing. Even when i have the switch on Defrost it still comes through the two vents.

My centers barely work, too. I guess I just learned to live with it.

01taco4x4
06-21-2005, 04:46 PM
The ducts arent the problem. When you change it to vents it just keeps blowing to the floor. Ride around like that a couple days and itll eventually flip up. But it never fails once i get it back up on vents some dork will get in and go to turning knobs and through it back to the floor. :mad: :mad:

TRD SyRuP
06-21-2005, 06:39 PM
well the unit..to make the air cold..

and the knob was missing a plastic part at the back of it..like where it clicks into place under the vents deep int he dash..

TACORICAN
06-21-2005, 11:27 PM
Would this be why the air stays comming out of the sides and the floor?

01taco4x4
06-23-2005, 08:28 AM
I guess soon as i get some extra time i am gona take mine apart and see if i cant figure it out on my own with out paying someone else to do it.

CanTaco
07-07-2007, 01:34 AM
Just had an issue with my selector knob stuck in two positions but I've also had problems with airflow from the center vents on my 99. I checked the linkages on the floor on the right side of drivers side and managed to unstuck the linkage for my selector knob.

I honestly think the center vents don't blow cause of design problems. Alot of ppl have the same issue.

MikeAWood
07-10-2007, 08:34 PM
on my '02 D-Cab, the louvers are driven my small servos in the dash. it's possible that your louvers are full of dust dirt or that the servos have poped off or come loose. take a look under the drivers side of the dash and change the selection of the settings and you should hear the servos move. if they sound like they are laboring or making a bad noise, then that might be your problem.

For those of you that have it coming out the side when the setting is on Defrost, IMO, that is normal. It is used to defrost the side windows. I could be wrong, but I'd bet they are that way on purpose.

MikeAWood
07-10-2007, 08:51 PM
No servos in his truck.

hum...The original poster responded that he had an 02..Figured it would be the same as my 02?! Guess not?