: Turn Signal Problems


kirk1005
02-15-2007, 09:54 PM
I am having problems with my drivers side turn signal. When my headlights are off, they work perfectly. When I turn the headlights on, the blinker light stays on in cab and both the front and rear lights stay on continuously. I have changed the bulbs, but am at a loss for what to do next. I'm not very good with vehicles, but am trying to learn. Any help would be much appreciated. Thanks.

HoT_DoGgIN
02-15-2007, 10:43 PM
sounds to me like you have a cross somewhere... trace your positive leads between your headlights and turn signals, and see if they aren't touching/rubbing etc to the point that current can flow through both?

kirk1005
02-15-2007, 10:49 PM
Thanks, if they are, what is the fix? Thanks again.

blown4runner
02-16-2007, 12:40 PM
Thanks, if they are, what is the fix? Thanks again.
fix the wire... What is probably happening is exactly as was stated above, you have some electrical interference backfeeding into the system. Trace the wires and look for damage, signs that someone has been wiring aftermarket accessories in, anything not factory or broken in association with the circuit... then repair the wire(s) appropriately. You'll need a multimeter, EWD for that systems circuit and a basic knowledge of how electricity works to start... and maybe some extra wires, electrical tape, a set of dykes, some solder and soldering iron, etc once the problem has been found

tacotoy
02-16-2007, 07:03 PM
ooo oooo i know this one and nicole doesn't. you have a trailer wiring setup on your truck. these usually go bad after a while ( it converts your brake and turn lights into one light.) when they short out you will see all sorts of crazy things happen. running lights on with the brakes and yada. if it is aftermarket look along the frame on the drivers side by the rear. it should just be tagged onto the nessecary wires. cut and remove( and replace if you need it) if it is factory you might want to check the FSM for your truck but it is usually behind the seat or under the xtra cab portion.

sexy.taco
02-16-2007, 08:06 PM
ooo oooo i know this one and nicole doesn't. you have a trailer wiring setup on your truck. these usually go bad after a while ( it converts your brake and turn lights into one light.) when they short out you will see all sorts of crazy things happen. running lights on with the brakes and yada. if it is aftermarket look along the frame on the drivers side by the rear. it should just be tagged onto the nessecary wires. cut and remove( and replace if you need it) if it is factory you might want to check the FSM for your truck but it is usually behind the seat or under the xtra cab portion.
yeah Rich... I know about that. Remember when Dan came out to Denver and I fixed his taillight problem... it has EVERYTHING to do with the trailer wiring. I was being generally vague because I try not to get too specific in diaging vehicles 3 states away with a bare minimum of info... lol! The harness ecu (if dealer or factory installed) will be under the LF seat on an xtra cab and behind the left side of the rear bench seat on a DC... hehehehe :p

silly, silly Rich... you may be god with the special Nicole decoder ring but I do know some things every once in a while.... *long pause* I think :D

tacotoy
02-16-2007, 11:42 PM
yeah Rich... I know about that. Remember when Dan came out to Denver and I fixed his taillight problem... it has EVERYTHING to do with the trailer wiring. I was being generally vague because I try not to get too specific in diaging vehicles 3 states away with a bare minimum of info... lol! The harness ecu (if dealer or factory installed) will be under the LF seat on an xtra cab and behind the left side of the rear bench seat on a DC... hehehehe :p

silly, silly Rich... you may be god with the special Nicole decoder ring but I do know some things every once in a while.... *long pause* I think :D


every once in a very long ass while lol

sexy.taco
02-17-2007, 04:55 PM
every once in a very long ass while lol
speaking of which, I am not sure when that last time was... lol! :)

tacotoy
02-17-2007, 06:40 PM
lol you might be coming up pretty soon again then lol


hows that fix going kirk?

blown4runner
02-20-2007, 11:24 AM
lol you might be coming up pretty soon again then lol
I guess I had a good day... lol! So hows the snow and cold in Colorado, I was out on the SF bay yesterday cruising around Alcatraz and stuff in my friends' very large boat enjoying the mid 70 degree sun!!! :p

kirk1005
02-22-2007, 03:01 PM
I found a wire that had come completely out of the trailer wiring harness. I'm pretty sure this is the problem, but havent tried to work with it yet. Thanks for all the advise everyone, will keep you posted on what happens when I try to fix it this weekend...

kirk1005
04-17-2007, 09:22 AM
the light issue I was having. After messing with it for almost 2 months, I finally got a fix. It was pretty expensive, but a needed fix for multiple problems. I traded in my Taco for a 2002 4Runner. It killed me to do it because I loved my PreRunner, but I needed the extra seat in the back for my 3 year old. I really didnt like her riding in the front seat anymore. Thank you all for the advice.