: Broken sway bar link??


hopper
10-15-2007, 06:46 PM
Not to long ago I changed out my sway bar bushings trying to get rid of my thump in the front end driver side. Well its still there and every so often I check under to see if anything is new and.. today there was!
Driver side sway bar link bent and broken and passenger side bent and on way to broken. Here are some pictures.
Passenger side \/
http://i121.photobucket.com/albums/o232/hoppy06/sway%20bar/100_1962.jpg
Driver side \/
http://i121.photobucket.com/albums/o232/hoppy06/sway%20bar/100_1961.jpg
http://i121.photobucket.com/albums/o232/hoppy06/sway%20bar/100_1960.jpg

What could cause the links to bend and break like this? I did a little offroading to go shooting on the 13th but nothing that would make me think I would have done this.

06SSTaco
10-16-2007, 03:40 AM
:eek: Holly Shit!!!!

hopper
10-16-2007, 03:42 AM
:eek: Holly Shit!!!!

HAHA yep!

06SSTaco
10-16-2007, 03:46 AM
HAHA yep!

Damn Cody that Sucks. Do you think it could be caused by bottoming out the suspension?

06SSTaco
10-16-2007, 03:50 AM
BTW, Happy B-Day, I missed it, haven't been on in few days.

hopper
10-16-2007, 03:51 AM
Damn Cody that Sucks. Do you think it could be caused by bottoming out the suspension?

I dont know. I replaced the sway bar bushings and tightened the end links while still on jacks and someone said that it may have "pre loaded the parts" and then I have someone saying that, that is BS and may be due to worn out shocks. :confused:
I went shooting for my b-day on the 13th and drove my 4runner on side roads but nothing that would make me think that this would have happened. And there isnt the new dust that would be on there from that so it must have happened after.:2cents:

Thanks!:D

06SSTaco
10-16-2007, 03:58 AM
I dont know. I replaced the sway bar bushings and tightened the end links while still on jacks and someone said that it may have "pre loaded the parts" and then I have someone saying that, that is BS and may be due to worn out shocks. :confused:
I went shooting for my b-day on the 13th and drove my 4runner on side roads but nothing that would make me think that this would have happened. And there isnt the new dust that would be on there from that so it must have happened after.:2cents:

Thanks!:D

I would agree from the pics it looks like it just happened. I can't really offer an opinion, I just don't know enough about IFS, this is my first one and I,ve never worked on it.

my034runner
10-16-2007, 02:18 PM
PM Brett.:saw: :welder:

06SSTaco
10-16-2007, 03:48 PM
PM Brett.:saw: :welder:
X2

hopper
10-16-2007, 04:14 PM
PM Brett.:saw: :welder:

I know Brett has hook up with parts and I know he is a good fabricator to, but how are you thinking he can help me? I will more then likely get used end links for cheap and go from there.

crhannig
10-16-2007, 04:24 PM
I know Brett has hook up with parts and I know he is a good fabricator to, but how are you thinking he can help me? I will more then likely get used end links for cheap and go from there.

Since he is a toyota master tech, he might be able to tell you "Why" that happened and what it would take for it not to happen.:D

hopper
10-16-2007, 04:29 PM
Since he is a toyota master tech, he might be able to tell you "Why" that happened and what it would take for it not to happen.:D

I have been studing all day for my mid term...my brain aint around right now. :missingto :xcrazy:

That makes since now.

crhannig
10-16-2007, 04:37 PM
I have been studing all day for my mid term...my brain aint around right now. :missingto :xcrazy:

That makes since now.

Well I was kind of thinking that:D

damaged110
10-16-2007, 09:39 PM
i have replaced about 6 or seven endlinks just because of this problem. they were all on high milage trucks 100k or better. they get weak after time and break its not like they are strong to begin with. i have made a set stronger by welding a peice of tube that was cut in half around the shaft to make it stronger. get you a new set and make sure the frame bushings are lubed so the bar moves freely in the bushings and you will be fine. as for the clunk noise check your front struts when they are worn out they make a clunk noise over bumps. just my:2cents:

hopper
10-17-2007, 02:45 AM
i have replaced about 6 or seven endlinks just because of this problem. they were all on high milage trucks 100k or better. they get weak after time and break its not like they are strong to begin with. i have made a set stronger by welding a peice of tube that was cut in half around the shaft to make it stronger. get you a new set and make sure the frame bushings are lubed so the bar moves freely in the bushings and you will be fine. as for the clunk noise check your front struts when they are worn out they make a clunk noise over bumps. just my:2cents:

Ok thanks!!! Im working on a pair of used extended Dhoes for $650 w/ 4k miles on them.:D

damaged110
10-24-2007, 12:58 AM
did you get it fixed yet let me know if you need anything:saw:

hopper
10-24-2007, 02:31 AM
did you get it fixed yet let me know if you need anything:saw:

Ok thanks! I have some replacements in the mail.

General question for anyone, will i need longer end links with a lift?

7sx_Tacoma
10-24-2007, 06:30 PM
I should have my links in my garage somewhere...i'll look for them.

7sx_Tacoma
10-24-2007, 06:31 PM
oops. I didnt read the last post...well if you need any more I have some.

hopper
10-24-2007, 06:38 PM
oops. I didnt read the last post...well if you need any more I have some.

You have them in town? How much?