: Donahoe Front Coilovers


Taco_Man
03-31-2008, 07:19 AM
So I am having an issue with my drivers side CO. For some reason no mater how high I crank it up too it all ways drops down to a 1.5 in lift on that side. I have sent ICON (Donahoe) a email regarding this as well as I am calling today. I am a little tick off about this. If any one has some suggestion please let me know. Currently the the drivers side is sitting 1.5 in lower then the passenger side.

I cranked both side up to 3" when Matt and I did the rear lift last Wednesday. I had the max weight that is usually in the truck when I did this. So I am starting to think it is the coilover.

Taco_Man
03-31-2008, 09:26 AM
Just got off the phone with icon vehicle dynamics (donahoe) and I am going to have to put the stock coilover on and ship the new one's back to them. They also want me to take some photos of the the shocks and where they sit. Its nice to see some good customer service in the off-road industry. But it sucks that I have to do all that work once again.

devinsixtyseven
03-31-2008, 10:48 AM
Sounds like a bad coil. Great to hear IVD is taking care of you :kewl:.

Taco_Man
03-31-2008, 10:49 AM
Yep i feel the same way.

Taco_Man
03-31-2008, 11:26 AM
here are some pic's.

http://gallery.mac.com/innersparkmedia/100065/IMG_8824/web.jpg

Driver Side
http://gallery.mac.com/innersparkmedia/100065/IMG_8825/web.jpg
http://gallery.mac.com/innersparkmedia/100065/IMG_8827/web.jpg

Passenger Side
http://gallery.mac.com/innersparkmedia/100065/IMG_8826/web.jpg
http://gallery.mac.com/innersparkmedia/100065/IMG_8828/web.jpg

sl3807
04-02-2008, 07:25 PM
That is definately not right. I think you might be right, and I wonder if somehow ICON got the wrong spring on the driver side (maybe a 550# instead of a 650#)? Stranger things have happened. My driver side is set about 2 turns more than the passenger (two more threads exposed), and it sits pretty close to level.

From your pictures, it looks like both sides are set about the same, looks like the same amount of thread is showing.

Just went out and measured mine. 38" from the ground to the bottom of the fender, centered on the wheel (285/75r16). Drivers side has 1.625" thread showing, passenger is 1.5".

Not sure if this helps much, but I am glad to hear ICON is going to do something about it.

Before you unbolt everything, have you tried just cranking up the passenger side? If i remember correctly, with 1.5" of thread showing, I got a little under 2.5" of lift.

One other thought, are the cups (not sure what they are called) seated correctly at the bottom of the coils?

Taco_Man
04-02-2008, 07:45 PM
Your right after counting the threads they are about even. I may try cranking the drivers side up more.