Post pics of your engine bay! - Page 2 - TTORA Forum
Toyota Territory Off-Roaders AssociationToyota Territory Off-Roaders Asso
ciationToyota Territory Off-Roaders Association
     


Go Back   TTORA Forum > General Tech > Performance/Engine/Exhaust
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read



Welcome to the TTORA Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

ATTENTION: In an on-going effort to keep this forum spam free, the Forum Admin approves every new account before giving any posting rights to new users. Accounts are normally approved within 24 hours. Sorry for any inconvenience, but verification of every new account is what will continue to keep this forum spam free.

Reply
 
Thread Tools Display Modes
Old 02-05-2012, 01:57 PM   #31
PismoJoe
Senior Member
 
PismoJoe's Avatar
 
My Rig: 2002 Tacoma
Join Date: Apr 2010
Location: Pismo Beach, CA
Posts: 347
Default

Bored so I thought I would bump this thread.



First complete engine rebuild that I did on my 86 4runner
PismoJoe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-06-2012, 03:01 PM   #32
SilverLux
Member
 
Join Date: Jan 2012
Posts: 39
Default Mine

Here is mine in a 1995 SFA double Cab, I call it my 4Y Hairdryer. Efi'd the thing!!!

Last edited by SilverLux; 04-13-2012 at 03:14 AM.
SilverLux is offline   Reply With Quote
Old 02-08-2012, 08:17 AM   #33
cam-shaft
Senior Member
 
cam-shaft's Avatar
 
Join Date: Feb 2008
Location: Portland, Oregon
Posts: 292
Default

Quote:
Originally Posted by PismoJoe View Post
Bored so I thought I would bump this thread.



First complete engine rebuild that I did on my 86 4runner
Very nice! Is the valve cover raw or did you do a clear powder or some color on it?
cam-shaft is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hoe to post pics.??? Biggins Off Topic 58 03-09-2009 07:47 PM
how do you post pics? SP!N4L T4P General Discussions 12 02-04-2008 11:33 PM
please post pics. Nowhere2wheel Solid Axle Swap Tech 5 11-21-2006 12:18 PM
how to post pics cruiserbent Newbie Tech 4 10-13-2006 07:03 PM
How do i post pics or links to pics? RCPractitioner Off Topic 1 03-19-2005 10:52 PM


All times are GMT -6. The time now is 11:27 AM.




Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.