Clicking Front end ( suspension ???) - TTORA Forum
Toyota Territory Off-Roaders AssociationToyota Territory Off-Roaders Asso
ciationToyota Territory Off-Roaders Association
     


Go Back   TTORA Forum > Vehicle Specific Tech > Late Tacoma Tech
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read



Welcome to the TTORA Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

ATTENTION: In an on-going effort to keep this forum spam free, the Forum Admin approves every new account before giving any posting rights to new users. Accounts are normally approved within 24 hours. Sorry for any inconvenience, but verification of every new account is what will continue to keep this forum spam free.

Reply
 
Thread Tools Display Modes
Old 07-15-2009, 10:35 AM   #1
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default Clicking Front end ( suspension ???)

Hey .. over the past week I have developed a clicking sound over small bumps and uneven grounds. It sounds like a click sound that you normally would get when anti rattle clips go on your brakes but I have tried applying the brakes over the bunmps and still get the clicking? I have also checked out the sway bar links and still getting this .. driving me nuts with 10,000KM on the truck

Anyone have this before. Its on my 09DBL Cab 4x4

No feeling or vib. Just a click over anything uneven or quick ruts in the road. It sounds loike something in the front suspension but i have checked everything and it all seems fine to me. The CV boots look fine and it engages and disengages fine .. its not the sway bar cause I putted that off a few nights ago to see .. I have pro comp wheels could they be doing anything? Althought I had these on for 9000kms without a sound.

Its like whenever the suspension go under load its clicks and whenever the front tires fall into say a pothole its clicks or when they make contact with a bump? Im confused and I hate it .. the truck is new and it clicks the whole way down a street.
rocket67 is offline   Reply With Quote
Old Sponsored Links
Advertisement
Old 07-15-2009, 10:58 AM   #2
NORTHWESTTACOMA
Senior Member
 
NORTHWESTTACOMA's Avatar
 
Join Date: Sep 2007
Location: Western Washington
Posts: 421
Default

I have what sounds to be the same issue on my 05'. I get it over bumps & stuff, but moreso when I apply the brakes. It's a really wierd clunk. Like someone tapped a wrench on the frame. I mostly notice it when backing up, apply the brakes & clunk. Then put it in drive, move a couple of feet, apply brakes & clunk.
For the longest time I thought it was the rear brakes. I finally had my wife get in the truck & roll it back and forth, tapping the brakes. It's definetely coming from the front.
I am doing an oil/filter change & tire rotation tomorrow night. I am going to try and track down the culprit & if there's daylight left, i'm gonna install my aftermarket Trans cooler & gauge
__________________
05 Silver Tacoma DC 4x4, Extang tonno, TRD Skid Plate, N-FAB lightbar w/4 Hella 500's, Cornfed spacer, Black Raceline Renegade's on 33" M/T MTZ's

91 Jeep XJ, 4.5" Rusty's lift, 33" ProComp
http://tinypic.com/r/dbruwh/7

66' VW DRAG BUG - 9.90@124.57 in the 1/4.
http://i149.photobucket.com/albums/s...d/IMG_1296.jpg
http://i149.photobucket.com/albums/s...d/IMG_1321.jpg
NORTHWESTTACOMA is offline   Reply With Quote
Old 07-15-2009, 02:13 PM   #3
Alexe
Senior Member
 
Alexe's Avatar
 
Join Date: Dec 2007
Posts: 187
Default

my truck with 21,000km makes so many different clicks creaks squeaks rattles and groans that i dont even know where to start. but yea i have a similar noise to what you describe. usually does it when going in and out of the driveway or speedbumps
__________________
Southern Ontario Toyota Trucks

www.sontt.com
Alexe is offline   Reply With Quote
Old 07-16-2009, 09:59 PM   #4
FatWhite
Newbie
 
Join Date: Aug 2008
Location: Virginia
Posts: 2
Default

I was experiencing the same issue in my '06 double cab. I had to do a 3 point turn every morning to get out of my driveway and would hear it when backing up and then again when moving forward. I eventually tracked it down to the front and after changing the brake pads it has gone away. I also changed the rotors, but it might not be necessary. My Mechanic (Brother-in-law) said that there was a pretty significant groove cut in to one of the pads and a rock or something trapped between the rotor and pad could have been causing the noise. After the rotor and pad change there has been no more noises/issues!

I hope this helped.
FatWhite is offline   Reply With Quote
Old 07-16-2009, 10:45 PM   #5
gdctaco
Senior Member
 
gdctaco's Avatar
 
Join Date: Apr 2007
Location: Ontario, Canada
Posts: 154
Default

if your still under warranty take her in.
__________________
06 xcab OR 4.0 M/T
RR diff mod
TRD CAI
in cab 110V
265/75r16 Dunlop rover
Bilstein 5100's
gdctaco is offline   Reply With Quote
Old 07-17-2009, 12:10 AM   #6
freeze
Veteran Member
 
freeze's Avatar
 
Join Date: Aug 2007
Location: Calgary
Posts: 632
Default

definitely take it in...

are you still stock besides the wheels?
__________________
Canada Toyota 4WD Association
www.CT4WD.com
______________
2007 Toyota Tacoma TRD Offroad
All-Pro Bumper-skids-Sliders-Long Travel-3" Leafs/Fox 2.5 F&R/T-Max 10000/LF 240/MTZ

1981 Toyota Truck Sr5
Marlin 4"-crossover-4.7-TrannyHD-front&rear tube bumper/Warn 9000/5.29HP ARB f/5.29 ARB r/Champion Beads/MTR
freeze is offline   Reply With Quote
Old 07-18-2009, 10:41 AM   #7
cdudash3
Newbie
 
Join Date: Jul 2009
Posts: 11
Default clicking sound in front end

I got the same sound in my 05 taco. Took it into a mechanic and he took the front end apart said everything looked fine. checked all things that move and while on the lift hung on anything that might make that sound. He called around to see if anyone else heard of it and no one knew. He said that he knew of dodge having a similar issue in caravans and that it had something to do with a sealed joint that moved in and out of place and that the lube in it has gone. he is currently looking into it for me and will get back to me. He thinks that there is something that can be done. Do you notice it less when it rains?
cdudash3 is offline   Reply With Quote
Old 07-18-2009, 06:21 PM   #8
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default

Quote:
Originally Posted by freeze View Post
definitely take it in...

are you still stock besides the wheels?
I have 5100's set at 2.5
rocket67 is offline   Reply With Quote
Old 07-24-2009, 03:04 PM   #9
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default

took it in and got the we cant cover cover it under warranty because my " your truck is heavily modified" meaning 5100's set at 2.5 and aftermarket headlights ( lol BHLM) and aftermarket intake and exhaust both TRD. Dealers are a pile of shit if ya ask me .. anyways it still clicks
rocket67 is offline   Reply With Quote
Old 07-24-2009, 07:40 PM   #10
JoeTacoma02
Veteran Member
 
JoeTacoma02's Avatar
 
Join Date: Jun 2006
Location: Beaverton, OR
Posts: 643
Default

Quote:
Originally Posted by rocket67 View Post
Hey .. over the past week I have developed a clicking sound over small bumps and uneven grounds. It sounds like a click sound that you normally would get when anti rattle clips go on your brakes but I have tried applying the brakes over the bunmps and still get the clicking? I have also checked out the sway bar links and still getting this .. driving me nuts with 10,000KM on the truck

Anyone have this before. Its on my 09DBL Cab 4x4

No feeling or vib. Just a click over anything uneven or quick ruts in the road. It sounds loike something in the front suspension but i have checked everything and it all seems fine to me. The CV boots look fine and it engages and disengages fine .. its not the sway bar cause I putted that off a few nights ago to see .. I have pro comp wheels could they be doing anything? Althought I had these on for 9000kms without a sound.

Its like whenever the suspension go under load its clicks and whenever the front tires fall into say a pothole its clicks or when they make contact with a bump? Im confused and I hate it .. the truck is new and it clicks the whole way down a street.
Funny thing...in April I hit a big hole someone dug up at the beach while back home in oregon and bent the bottom of my front passenger side shock. Bought the adjustable 5100 bilstein and replaced the 2 front shocks...and left it at stock height(I had a spacer kit at that time).

Anyway I noticed those clicking noise as well at slow speeds(like maybe under 25mph) and didn't really care because I was getting a new suspension set up.

Finally got the new suspension installed(Camburg coilovers and Camburg UCA) and still had that damn noise. So today I had my girl drive my truck back and forth and from what it sounds like it sounds like something around the brake area..

Just thought I would share my situation also..let us know if anyone gets this thing fix. Thanks.
__________________
2005 Tacoma 4x4 Double Cab TRD Off-Road

||Mall Crawler||

My Build

Gitout.com

JoeTacoma02 is offline   Reply With Quote
Old 08-13-2009, 07:42 PM   #11
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default

still clicks and getting worse on dry days also getting the frotn diff vibration too which goes away when switched into 4x4. Looks like this is going back to stock which pisses me off cause I love the look.
rocket67 is offline   Reply With Quote
Old 08-14-2009, 07:34 AM   #12
07TXTRD
Member
 
07TXTRD's Avatar
 
Join Date: Aug 2008
Location: El Paso, TX
Posts: 69
Default

Quote:
Originally Posted by rocket67 View Post
Hey .. over the past week I have developed a clicking sound over small bumps and uneven grounds. It sounds like a click sound that you normally would get when anti rattle clips go on your brakes but I have tried applying the brakes over the bunmps and still get the clicking? I have also checked out the sway bar links and still getting this .. driving me nuts with 10,000KM on the truck

Anyone have this before. Its on my 09DBL Cab 4x4

No feeling or vib. Just a click over anything uneven or quick ruts in the road. It sounds loike something in the front suspension but i have checked everything and it all seems fine to me. The CV boots look fine and it engages and disengages fine .. its not the sway bar cause I putted that off a few nights ago to see .. I have pro comp wheels could they be doing anything? Althought I had these on for 9000kms without a sound.

Its like whenever the suspension go under load its clicks and whenever the front tires fall into say a pothole its clicks or when they make contact with a bump? Im confused and I hate it .. the truck is new and it clicks the whole way down a street.
I have the same clicking over speed bumps. When I took it in to the dealer, they could not find anything. For what it's worth, when I used to have a 1996 Eclipse it also clicked over speed bumps, turned out to be the tie rod ends.
07TXTRD is offline   Reply With Quote
Old 08-14-2009, 05:13 PM   #13
DesertRat
Member
 
Join Date: Apr 2006
Location: Tucson, Arizona
Posts: 81
Lightbulb I think I have the answer....

My '06 Double Cab 4x4 TRD with 75K has been making the same noise now for quite a while. I thought it was brake slap from worn out pads but the brake shop said they were fine. After looking over the truck for the better part of a day, they finally put it up on the alignment rack and noticed that there was a substantial amount of play in my lower control arm. They were even able to reproduce the "metal clunk" noise by thrusting the LCA back and forth.

I do quite a bit of desert wheeling with my truck and it appears to have beaten up the suspension a bit.

I've been wondering about overhauling my suspension with a set of coil-overs. I guess that now would be a great time to add upper AND lower control arms to the deal.

To all of you experiencing similar noises/problems...check out those lower control arms for free play.
__________________
RUSS
DesertRat is offline   Reply With Quote
Old 08-14-2009, 06:28 PM   #14
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default

K nexts on my list to check out tomorrow. Its a 09 with 15,000KM's. I took it to my dealer but I have 5100's @ 2.5 so they basically told me its prob not going to be covered.

Thanks i'll check tomorrow
rocket67 is offline   Reply With Quote
Old 08-14-2009, 09:06 PM   #15
DesertRat
Member
 
Join Date: Apr 2006
Location: Tucson, Arizona
Posts: 81
Default

Just did a bit of checking for parts. I might just choose to replace all the front control arm bushings (upper & lower). Here are the part numbers:

4865404040 X 2 (Lower Front)
4865504020 X 2 (Lower Rear)
4863204020 X 4 (Upper)

The cheapest I've found them so far is from Carson Toyota Parts for about $345 including shipping. This isn't exactly small change but it's ALOT less than buying new lower control arms.
__________________
RUSS
DesertRat is offline   Reply With Quote
Old 08-14-2009, 10:00 PM   #16
fast frank
Veteran Member
 
fast frank's Avatar
 
My Rig: 2001 Tacoma 4X4 Dcab
Join Date: Dec 2004
Location: Houston, Texas(Woodlands)
Posts: 2,837
Default

Before you guys go hog wild on this...

Whenever I flex my truck in any way at all, it clicks.

I searched the fuck out of it until I found it, and it's the freakin aluminum bash plate on the front.

This one:



The frame moves any time I twist it even the smallest amount, like a speed bump or pulling into a driveway, and when it does the bolts that mount the bashplate move around in their holes . I can torque the crap out of the bolts, but the clicking comes back in a short time.

The easiest way to prove this is to take the skid/bash plate off the truck and drive it.

I got a nickle that says it's your noise.
__________________
2001 Double Cab V6 Auto Tranny 4WD TRD Offroad.

Bone Stock and Loving Every Minute Of It.
fast frank is offline   Reply With Quote
Old 08-14-2009, 11:03 PM   #17
DesertRat
Member
 
Join Date: Apr 2006
Location: Tucson, Arizona
Posts: 81
Default

My metal to metal "clunk" noise happens even on glass smooth pavement. I was sure it was the brakes until my local brake shop guy showed me the play in my lower control arm.

You can actually take the wheel (while on an alignment rack) and chuck it from side to side and reproduce the "clunk" sound I hear when I sometimes hit the brakes. It dosen't seem to matter if I'm going up a hill, down a hill, or on flat level ground.

It's just like what NORTHWESTTACOMA said: "I get it over bumps & stuff, but moreso when I apply the brakes. It's a really wierd clunk. Like someone tapped a wrench on the frame. I mostly notice it when backing up, apply the brakes & clunk. Then put it in drive, move a couple of feet, apply brakes & clunk."

I know there are probably dozens of things (like skid plates) that can make noises in the front end. I even found a TSB from Toyota that applies to 05 & 06 Tacomas that addresses an audible squeak or rattle in the front bumper extension (NVH NV003-06).

At least for me, I think I've found my demon...
__________________
RUSS
DesertRat is offline   Reply With Quote
Old 08-15-2009, 07:03 AM   #18
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default

I have driven the truck with both the sway bar pulled out and the bash/skid off .. still got it. Gonna check into the LCA's today and come back with an update. They really shouldnt be done yet thou its a 09 with 15,000km's
rocket67 is offline   Reply With Quote
Old 08-19-2009, 05:28 PM   #19
rocket67
Member
 
Join Date: Aug 2007
Location: Canada
Posts: 63
Default

found it !! front bumber extensions
rocket67 is offline   Reply With Quote
Old 01-06-2010, 06:11 AM   #20
StockRed
Member
 
StockRed's Avatar
 
Join Date: Nov 2006
Location: Oceanside
Posts: 48
Default

I'm having the same sound as NorthwestTacoma. I was trying to recreate it yesterday and the only way I could was to take my foot completely off the brake and role forward then apply the brake (clunk) then hit reverse with my foot off the brake then apply brake (small clunk). I had a friend move the truck back and froth for a few min and found it to be coming from the front driver side wheel area ( a lot of help right). It sounded like something was tapping the brake dust cover and only on the drivers side. I also feel a slight vibration from that wheel. I'm here in MI and its 20 degrees out so when the sun comes out on Monday I'll give it a look. If I find anything Ill post my results.
__________________
06 DB Cab TRD Prerunner w/h TTORA sticker
TRD cat back, 265/75/16 BFG's KO's
TRD seat covers/ LEAR color matched Tonneau cover
AFE stage 2 coldair (just for the noise)
2.5 Camburg Coilover's with AAL
BS 5100's in rear Ubolt flip kit from ALL PRO
Toy's
StockRed is offline   Reply With Quote
Old 01-06-2010, 07:33 AM   #21
lovemytruck
Member
 
lovemytruck's Avatar
 
Join Date: Feb 2007
Location: Connecticut
Posts: 73
Default

I had a clicking sound develop a few months after having the suspension TSB performed on my 2005 taco. If I drove over a manhole cover or small pothole I would hear it when driving with the drivers window open. Turned out the top nut on the drivers side shock was a little loose and the washer was slapping around on there. Hope this helps.
lovemytruck is offline   Reply With Quote
Old 01-06-2010, 10:40 AM   #22
dirtytoy
Senior Member
 
dirtytoy's Avatar
 
Join Date: Jul 2007
Location: SoCal
Posts: 196
Default

Check your inner CV's especially the driver side. I to had a clucky feel/sound on my '06 and noticed alot of play in the inner CV's. In my case increasing the preload on my ICON coil overs fixed it.

Good Luck!!
__________________
Geo Dave

DMZ BUILD "in progress": http://picasaweb.google.com/DavewFerry/DMZTACOBUILD#

1982 hilux LB 4x4
1987 Xtra Cab 4x4 TRD
1989 Xtra Cab 4x4
1992 Xtra Cab 4x4

DMZ '06 TRD Tacoma 4x4 , Total Chaos +2" LT, ICON 9" Coilovers. RCV Ultimate Axles, TRD Cold airfilter, Custom Deaver 10 pack, Fox Resi in rear, BFG KM2 315/75R16, Chambers 16x8, Demello Sliders, All Pro stuff, Snugtop w/ windoors.

http://picasaweb.google.com/DavewFer...84663116958546
dirtytoy is offline   Reply With Quote
Old 01-07-2010, 12:28 AM   #23
NORTHWESTTACOMA
Senior Member
 
NORTHWESTTACOMA's Avatar
 
Join Date: Sep 2007
Location: Western Washington
Posts: 421
Default

I checked any play in the LCA. Couldn't find anything with the wheel hanging. This made the most sense to me because of the situation of when it occurs (same as StockRed). I am now thinking that it might be coming from the CV's. I think I started noticing the noise after installing my front spacers a few years ago. I have plans to do a oil/filter change & chassis lube this weekend. I will look further into this clunk sound. I will post what I find.
__________________
05 Silver Tacoma DC 4x4, Extang tonno, TRD Skid Plate, N-FAB lightbar w/4 Hella 500's, Cornfed spacer, Black Raceline Renegade's on 33" M/T MTZ's

91 Jeep XJ, 4.5" Rusty's lift, 33" ProComp
http://tinypic.com/r/dbruwh/7

66' VW DRAG BUG - 9.90@124.57 in the 1/4.
http://i149.photobucket.com/albums/s...d/IMG_1296.jpg
http://i149.photobucket.com/albums/s...d/IMG_1321.jpg
NORTHWESTTACOMA is offline   Reply With Quote
Old 01-07-2010, 06:47 PM   #24
dirtytoy
Senior Member
 
dirtytoy's Avatar
 
Join Date: Jul 2007
Location: SoCal
Posts: 196
Default

Quote:
Originally Posted by rocket67 View Post
found it !! front bumber extensions
yap! that's one of the spots if you are taking about the aluminum sub bumper? the pop rivets get loose - I through bolted them!
__________________
Geo Dave

DMZ BUILD "in progress": http://picasaweb.google.com/DavewFerry/DMZTACOBUILD#

1982 hilux LB 4x4
1987 Xtra Cab 4x4 TRD
1989 Xtra Cab 4x4
1992 Xtra Cab 4x4

DMZ '06 TRD Tacoma 4x4 , Total Chaos +2" LT, ICON 9" Coilovers. RCV Ultimate Axles, TRD Cold airfilter, Custom Deaver 10 pack, Fox Resi in rear, BFG KM2 315/75R16, Chambers 16x8, Demello Sliders, All Pro stuff, Snugtop w/ windoors.

http://picasaweb.google.com/DavewFer...84663116958546
dirtytoy is offline   Reply With Quote
Old 01-12-2010, 11:28 AM   #25
StockRed
Member
 
StockRed's Avatar
 
Join Date: Nov 2006
Location: Oceanside
Posts: 48
Default

NWTacoma,
I broke down and took the truck to the dealer. I moved the truck back and forth for the tech and recreated the clunk noise (sounds like someone taping the frame with a wrench). They called me a few hours later to say that both LCA's were loose. All they did was tighten them down and the clunk and the slight vibration was gone. This might not be your problem but worth getting a wrench down there and checking it out.
__________________
06 DB Cab TRD Prerunner w/h TTORA sticker
TRD cat back, 265/75/16 BFG's KO's
TRD seat covers/ LEAR color matched Tonneau cover
AFE stage 2 coldair (just for the noise)
2.5 Camburg Coilover's with AAL
BS 5100's in rear Ubolt flip kit from ALL PRO
Toy's
StockRed is offline   Reply With Quote
Old 01-22-2010, 06:07 AM   #26
StockRed
Member
 
StockRed's Avatar
 
Join Date: Nov 2006
Location: Oceanside
Posts: 48
Default

It came back!!! The dealer tightened up the LCA's and the clunk whent away for a day or so. Now its right back to the same ol clunk.

NOTE: my truck just hit 74K
__________________
06 DB Cab TRD Prerunner w/h TTORA sticker
TRD cat back, 265/75/16 BFG's KO's
TRD seat covers/ LEAR color matched Tonneau cover
AFE stage 2 coldair (just for the noise)
2.5 Camburg Coilover's with AAL
BS 5100's in rear Ubolt flip kit from ALL PRO
Toy's
StockRed is offline   Reply With Quote
Old 02-05-2010, 11:14 AM   #27
ericl808
Newbie
 
Join Date: Aug 2006
Location: Makawao
Posts: 6
Default

I had the exact same thing a few years back on my 01 dbl. cab. It took a few hours of one guy rocking the truck back and fourth and another under the truck listening to pinpoint. It turned out to be the knuckle connecting the sway bar to the lower arm.
ericl808 is offline   Reply With Quote
Old 02-05-2010, 11:56 AM   #28
tacomarotto
Veteran Member
 
tacomarotto's Avatar
 
Join Date: Jun 2009
Location: Marietta and Valdosta, GA
Posts: 533
Default

Quote:
Originally Posted by ericl808 View Post
I had the exact same thing a few years back on my 01 dbl. cab. It took a few hours of one guy rocking the truck back and fourth and another under the truck listening to pinpoint. It turned out to be the knuckle connecting the sway bar to the lower arm.
WOW there are alot of people expereincing this! im AMAZED. i have the "wrench tapping/clunking/metal sound comming from the front right. I did the same procedure that all of you took. got a friend to drive the truck/rocked it back and forth and listened for the clunk. i originally beleived it was comming from the lower arm.

i took it into the dealership and they told me it was comming from the swaybar and my lower control arm. NOW what reeeeally pissed me off as they had the fricken nerve to acually tell me that i need to buy a new sway bar assembly... i said um.... "ya... ok" and i said thanks for checkin and left. haha they tried to steal my money... so i laughed it off but was content they confirmed the sound.

i WD-40'ed the CRAp out the lower arm and the sway bar connections... it went away for about a day. idk how to fix this dang thing.
__________________
Tacoma TRD prerunner

My Garage

ΦΣK
tacomarotto is offline   Reply With Quote
Old 02-12-2010, 02:54 AM   #29
SilverStreak05
Senior Member
 
SilverStreak05's Avatar
 
Join Date: Jun 2005
Location: San Jose, CA
Posts: 326
Default

Check your inner tie rods.

My truck would clunk going over uneven surfaces. The passenger side inner tie rod was shot, the drivers side still seemed ok, but I replaced it anyway. No more noise.
__________________
2005 D-Cab 4x4
DR CO's, DR Rear Resi shocks, Deaver 11 pack
285/75/16 Nitto Terra Grapplers
SilverStreak05 is offline   Reply With Quote
Old 02-12-2010, 04:56 AM   #30
brock
Veteran Member
 
brock's Avatar
 
Join Date: Jul 2005
Location: southern CA
Posts: 3,578
Send a message via AIM to brock
Default

sound like any of this? lol.

http://vimeo.com/9390458
__________________

| 2005 Tacoma | Total Chaos LT | Richer Racing 62s | BBR Bumpers |

brock is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FRONT CLICKING NOISE SOLVED!!!!!!!!!!!!! by myself I might add :) micron929rr PreRunner Tech 12 02-10-2011 06:55 PM
Clicking in the front nhrafan Early Tacoma Tech 1 01-13-2009 08:49 PM
Front clicking noise TACO 4X4 Solid Axle Swap Tech 44 08-05-2007 02:30 AM
clicking sound front left tripsevn7 Early Tacoma Tech 14 12-23-2006 12:59 AM
front end clicking/thumping shuvlhed1 Early Tacoma Tech 1 01-23-2005 02:59 PM


All times are GMT -6. The time now is 05:07 AM.




Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.