loud fuel pump? - TTORA Forum
Toyota Territory Off-Roaders AssociationToyota Territory Off-Roaders Asso
ciationToyota Territory Off-Roaders Association
     


Go Back   TTORA Forum > General Tech > Performance/Engine/Exhaust
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read



Welcome to the TTORA Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

ATTENTION: In an on-going effort to keep this forum spam free, the Forum Admin approves every new account before giving any posting rights to new users. Accounts are normally approved within 24 hours. Sorry for any inconvenience, but verification of every new account is what will continue to keep this forum spam free.

Reply
 
Thread Tools Display Modes
Old 04-21-2012, 06:10 PM   #1
tinkertoy
Senior Member
 
tinkertoy's Avatar
 
Join Date: Nov 2005
Location: maine
Posts: 324
Default loud fuel pump?

i have a walbro pump that came with 7th injector kit.
pump has always been louder then stock, which i think is normal, slight high pitched hum.
noticed slight gas smell the other day then pump got louder, and from outside the truck you can hear the pump and also air hissing. seemed like too much pressure building up.
no fuel spraying anywhere or any noticeable problems.
blocked vent, or clogged fuel filter? over 100k on stock filter
gonna start there and work my way $$$
any help or ideas appreciated!
__________________
-Simon

2004 Tacoma sr5 v6, trd supercharger, urd 7th injector, 2.2 pully, jba headers, airaid .jr, fm, mtr's, saw's, bilstein's, aal's
and my dog tinker.
tinkertoy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2012, 09:46 PM   #2
MooseBit
Senior Member
 
Join Date: Oct 2007
Location: New Hampshire
Posts: 307
Default

It could be the pump is coming loose from the high pressure rubber fuel hose inside the tank. The hissing may be fuel spraying out inside the tank.
MooseBit is offline   Reply With Quote
Old 04-21-2012, 10:42 PM   #3
mosk22rte
Senior Member
 
mosk22rte's Avatar
 
Join Date: May 2010
Posts: 471
Default

Trust your ears and nose. I know a lot of folks have used Walbro pumps without any incident, but they fall into that category of "functional, but not all that great." They are a fairly cheap pump.

That said, the first step would be to make sure it's still installed correctly. A PITA to check, but less of a PITA than a fire.
__________________
2002 Tacoma DC V6 PreRunner (converted to 5 speed and 4x4, with some other stuff, too)
1986 turbo 4x4 pickup (my money pit)
-
Converting an early Taco from auto to manual?
My PDF of first gen. Tacoma ECU pinout comparisons will help!
mosk22rte is offline   Reply With Quote
Old 04-22-2012, 08:19 AM   #4
wrauj
Veteran Member
 
wrauj's Avatar
 
Join Date: Mar 2008
Posts: 552
Default

After having my pump in for 3k miles or so it started whining really loud one day. Now I can always hear it. Its annoying but hasn't caused me any problems the 2 years its been whining.
__________________
Build Thread
http://www.ttora.com/forum/showthread.php?t=112036
wrauj is offline   Reply With Quote
Old 04-22-2012, 10:00 AM   #5
tinkertoy
Senior Member
 
tinkertoy's Avatar
 
Join Date: Nov 2005
Location: maine
Posts: 324
Default

guess ill pull the bed off and check pump out for safety.
might also call gadget and see what he has to say.
thanks for replies, keep em coming!
__________________
-Simon

2004 Tacoma sr5 v6, trd supercharger, urd 7th injector, 2.2 pully, jba headers, airaid .jr, fm, mtr's, saw's, bilstein's, aal's
and my dog tinker.
tinkertoy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel sending unit with walbro fuel pump $40 shipped Brian Veal Parts/Electronics/Wheels/Tires 0 12-21-2010 11:20 PM
Water in Power Steering? Loud Pump Findley Early Tacoma Tech 4 12-08-2009 07:00 PM
loud whining (power steering pump?) krazyk2030 Newbie Tech 3 04-15-2009 09:16 PM
fuel pump miketaco11 Newbie Tech 2 04-09-2007 06:40 PM
Fuel Cell/fuel pump questions Tacoma747 Early Tacoma Tech 3 10-04-2006 12:08 PM


All times are GMT -6. The time now is 11:54 AM.




Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.