TTORA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
hi everyone!!

I have a question for you guys.. I have a 02 4x4 Xtracab stick and well it dies whenever I hit the gas hard and take it over 4k rpm?

anyone heard of this before? lets say i'm at a red light and I floor it in first the truck dies once it redlines.. and will not start up for a good 10 seconds engine turns, kinda like if flooded. gas smell and all.. it dies in any gear and when in neutral as long as It redlines.

I took it to the dealer, they tested it and the truck would die on them too.. they said they cant find anything wrong with it.. and tested another 02 4x4 they had and the truck did the same thing.. Is this normal for 02 4x4 with manual trans???

I tow stuff sometimes and I do get near redline it sucks that it keeps turning off on me.

any ideas?

Thanks

*EDIT* specs are TRD 4x4 5Spd Xtracab V6
 

·
Registered
Joined
·
455 Posts
I have the same truck, and i have never had this problem. i do notice that is has a rev limiter.. but i never had it die on me.
how many miles are on the engine?
\when is the last time you did a simple tune up? plugs/wires clean maf ect.?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
its got 32K miles on it and just minor service done to it.. ive cleaned the MAF, but havent changed wires/plugs.

theres another taco at the dealer with same specs that does the same thing, at first I thought it could be the fuel filter but dealer says its not and yea the rev limmiter kicks in at redline.. I can get to that point if I ease the gas.. but if I hit it then it dies
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
Could it be sparkplugs?? that somehow it floods and the plugs dont burn it up that could explain the smell of gas
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
The dealer says they cant find whats causing this issue..they say it all looks good. just that it shuts off at high rpm, what do I do now?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
hey get this!

dealer claims they had a toyota factory tech go out.. and check it and say nothings wrong and that they cant find the problem. now they Have another truck in the dealer with my same issue.. ?????

also I called toyota to speak to someone about this.. after I explained everything that was going on they said "go through your dealer, they have the tools necessary to fix your problem. Thanks for calling tho, we will document your input and the Higher ups will know"

so now the dealer has 2 trucks with the same issue.. and they say nothing electronic is wrong, plugs, cables.., MAF, fuel filter, pump etc are all in working condition!!

what the heck and the guy wants $80 for the work done on it
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
fixed

The dealer just called saying the fixed the prob.
they said its the Throtle body
and thats its fixed now


Dunno how that got messed up
 

·
Registered
Joined
·
2,160 Posts
Yeah, throttle by wire throttle bodies are known to go out on 01-04 Tacomas but Toyota doesnt want to admit to it. They run like $1k so your lucky the dealership is replacing it under warranty.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #9
truck feels heavy

wow $1k??

the truck feels so much slower now tho :( it feels heavy Dunno why
 
1 - 9 of 9 Posts
Top