TTORA Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My '98 2.7 was running real bad, CEL came on and I pulled codes 0300 and 0301 (misfires) . Took it to the dealer, confirmed codes, they did a compression test, and told me #1 cyl. was @50psi. Then they said it's probably valves, and for $2,500.00 they could do a valve job. I said thanks, but no thanks, did my own compression test and got #[email protected], #[email protected], #[email protected], #[email protected] Anyway, they weren't lying about the compression loss, but c'mon I can replace the whole head for alot less than $2,500.00, if it's even the valves. My question is, are there any other tests I can do to narrow the problem down? I guess it must be either valves, head gasket, or cracked head. Does anyone have some suggestions? Thanks in advance guys for any advice you can offer.

Jeff
NorCal
 

·
Registered
Joined
·
530 Posts
you can try pouring a small amount of engine oil in the spark plug holes before u do your compression test,if the compression goes up it's the rings worn out,if compression stays low,then more than likely it's bad valves..how many miles do you have on the truck?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hey 2k,
thanks for responding. My truck has 80,000 miles. It doesn't smoke either, but smells like it's burning rich. Yeah you're right, I should have done the oil in the the plug holes thing first, my bad.
 

·
The Satanic Panic
Joined
·
609 Posts
does anyone think it could be a possibility of carbon build up on the valves, my friend had a similiar problem with sputtering, and had a fuel injection clean up on his engine and ran fine after that :confused:
 

·
always a Toyota lover at heart
Joined
·
1,114 Posts
I have a spare head for a 2.7 sitting in my storage
I bought it off another member a bout a year ago, paid $500, would like to recover some $$$
I can send you pics
I was told it is NEW, has some spare parts, may need gaskets
 
1 - 5 of 5 Posts
Top