TTORA Forum banner
1 - 20 of 66 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter · #1 ·
well after 1 month ( two weeks waiting for new highsteer arms that didn't work.) i finished the 3 link late last night. last thing left to do is to bleed the power steering, i was so tired and the battery was shit because like an ass i left the keys in the ignition the night before. the battery was on the way out anyway. i was so tired i didn't get any pics so i'll take them today before the rain. i need to do some light wheeling to quadroople check everything.

i'll have pics tonight. any questions just ask. i'm no sas expert, this was only the second one i've seen and the first i've touched but i can help with anyone who is using the D44. wasn't as bad as i thought but it still sucked doing it.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #3 ·
i was in such a rush to get the thing out on the road before dark last night, final stupid things like installing the locking hubs, bleeding the power steering, adding front diff fluid, zip tying hoses becase i ran out of brackets, so i forgot the camera in the garage. ( garage is at my mother's house )

it drives well, needs an alignment, i think i'm going to need spindle shims does anybody know where to get them?

anecdotal comments huh? - well. everything fit really tight. the d44 is a narrower axle than this kit was designed for so everything was tight and had to be planned out before even a tack was placed. thank god some people where ahead of me in the build and showed me what they had for problems, it helped out alot knowing that the top link mount was screwed up on the D44 truss. easy fix.

instead of rotating the knuckles first I cut them and left them free then pointed the pinion at the t-case then rotated the knuckles. much easier. and more accurate.

because the panhard was designed to be floating over a toyota center section ( like allpro's axle or a diamond ) where the front is more streamline instead of square like a D44 or D60 it was rediculousely tight. I had to make my own lower panhard mount and added plates to the drivers side frame rail to lower the frame side panhard mount. worked out great. perfectly parrallell with the draglink now.

To clear the panhard mount and havea lower ride height i had Harsh terrain custom tapper a set of their highsteer arms with the iner hole tappered from the bottom to move the tierod lower and out of the way. well i waited two weeks ( not a big deal i ordered the draglink and tierod from them then a week later decided on the custom arms so the long wait was my fault) well if i didn't feel like the dumbest shit in te world when the tierod hit the front diff cover. thank god i still hade the factory location on the knuckles and the tierod was long enough to safely mount out there. that's where it will stay for now.


hardest most agonizing part of staring and head scratching was when i had to mount the lower shock mounts, they had to be out of the way of the callipers and the lower link bolts. -
pain in the ass. measure-go to the other side-measure-turn the wheel-measure-hold mount there with bottom of coilover in place while measureing by yourself-measure. it took a good 45 minutes and i found out i couldn't mount them the same way from one side to the other becuse of the lower link bolt n one side and the actual mount on the other side. no biggie their adjustable.

despite the hangups the kit went together verry well. like i daid before i had a plan because of the problems everyone else had along the way. it goesin for an alignment in an hour and ahalf. so i'll let you know how it drives then. and i'm going to go and get the camera for a test run before the alignment.

it flexes almost perfectly with the allpro 3" rears. i thought for sure it would flex like hytenor's beffore he put the chevy's in. but it's seriouely almost perfect. pictures later today.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #7 ·
i have a problem with the draglink though. the tierod ends do not have enough travel in them. i'm binding on the draglink while the passenger side is drooping. anbody have any ideas? hiems maybe? i dont want to run a limit strap shorter on the passenger side just because of the draglink.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #8 · (Edited)
the meat fucks here at the allignment shop took one look at it and said no problem. two minutes later they asked me to come out back and help. so i went out and gave myself an alignment.

drivers side castor was 4.0
passangers side was 5.0

Fuck me. my angle finder sucks.

camber on the drivers side was 0.1
passanger side was -0.4

toe was in the green i can't remember what it was right now. but it is within specs.

mother fuckers had the balls to try to charge me full price for doing my own fucking allignment. $70 my ass i gave them $50 and walked out the door.

surrisingly it drives really good. i need a steering stabilizer but othr than that it handles really well on bumps. once i get the slight ( verry slight ) wonder out of the steering it will be perfect., i think it will drive better than the IFS.
 

·
Registered
Joined
·
680 Posts
Congrads I'll be bugging the hell out of you over the next few weeks. so be prepaired.

glad it all went pretty smooth after hearing shovelracers and Tony56's problems.

cant wait to see the pics
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #11 · (Edited)
well here are some garage pictures. some flex shots will come tomorrow, i'm wheeling a tough stock trail. shakedown run.

well i'll let the photo's speak for themselves. oh and i got the frame height down to 20- 3/4" i was just trying to level it out.
















click on the link and go to SAS if you want to see them all. i didn't take many pictures. i was too busy working.

anybody know what kind of travel i can expect out of heim joints as steering link ends for the draglink? my tierod ends are maxing out and limiting travel on the passenger side.

i would run safety washers so there wont be any worries. just curious.


and i know one of the Hella's is broken, it happend on the last trail ride before it went under the knife.
 

·
Going John Galt
Joined
·
31,846 Posts
dang, I can't believe your ride height, LOL how much shock shaft is left riding that low? I'm at 25" up front and have about 2.5" of shaft left. We are going to cut off the lower shock mounts on Sunday and replace them with Ruffstuff's new mounts (his kid designed them after seeing the AP mounts) and that will drop things a good 2". I'll then crank another inch into the coils for at least 3" of up-travel and hopefully get things down to 24"
we'll see.

did you get the ride-adjustable shocks?

do you have lift shackles in the rear to go with the 3" springs?
 

·
Going John Galt
Joined
·
31,846 Posts
i've got about 3.5" of up travel. i have the mounts on the lowest point on the tube i could get them at. i'm leaving now to go wheeling. wish me luck. it's a 3.5 hour drive to get there and 3.5 hours back.
wow, down that low?! I sure hope you beefed the hell out of them with some sort of plating and gussets :eek:

have fun ;)
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #15 ·
wow, down that low?! I sure hope you beefed the hell out of them with some sort of plating and gussets :eek:

have fun ;)
i did some wheeling today. sort of easy stuff but harer than i wanted to do. it performed amazingly. i deffinatly don't need a sway bar. it doesn't lean that bad at all. the lower shock mounts performed perfectly. the bolts didn't loosen at all and no cracks in the welds and i made it home safely. before i wheel again the lower L bracket will be gussetted and the upper ( slug ) will be gussetted as well.

The passenger side is deffinatly noticibly binding while it droops. i knew that but didn't think i would be abe to tell on the trail. but I need to fix this soon. i will contact ballistic fab. about their missalignment spacers and safety washers for the draglink. i just need to know how much more rotation i would get if i ran heims over the TRE's. they are chevy 1 ton ends BTW.

i don't have any pics on my camera of me wheeling, i was still trying to get used to basically a new truck. that I wheeled for the first time today. the guy who took the majority of the pictures hasn't logged on yet. so once he does you will see them.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #17 ·
dang, I can't believe your ride height, LOL how much shock shaft is left riding that low? I'm at 25" up front and have about 2.5" of shaft left. We are going to cut off the lower shock mounts on Sunday and replace them with Ruffstuff's new mounts (his kid designed them after seeing the AP mounts) and that will drop things a good 2". I'll then crank another inch into the coils for at least 3" of up-travel and hopefully get things down to 24"
we'll see.

did you get the ride-adjustable shocks?

do you have lift shackles in the rear to go with the 3" springs?
do you have a link or photo? i looked on their wedsite and didn't see anything.
 

·
Going John Galt
Joined
·
31,846 Posts
do you have a link or photo? i looked on their wedsite and didn't see anything.
they aren't on his sight yet...have to call him.

If all else fails AJ can send you a set. He sells them as fast as he gets a batch in.
 
1 - 20 of 66 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top