TTORA Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
My toyota is having yet another problem.. (93 with 22re) When the key is turned on everything works and turns on except the starter. No click no nothing. It randomly just stopped starting.

I have been doing lots of work to this thing over the last week do to all the problems it has had. Ill try and give a run down of what I have done.

Last week I was working on the cylinder head and dropped a wrench on the alternator causing it to arc. It blew out the main 80amp fuse. After replacing that it seemed fine. I developed a power steering leak which leaked all over the alternator. Between the two the alternator burned up. Yesterday I replaced the alternator, charged the battery, replaced the ps line, and some other things. Started it up and test drove it with no problems. I brought it home and started it a few times while I was cleaning everything up. A few hours later I went back out and tried to start it and when I turned the key on everything worked except the starter would not turn over or even click.

Its been kind of a pain to start lately. Somedays it cranks and cranks, fuel pumping, and it had spark but wouldnt fire. The check engine light was on when it did this as well and when I scanned it there were no codes, the light just flashed continuously. Finally it would start after 10+ mins. Somedays it would be sluggish to crank over but would shortly fire up.


I checked all the fuses and they are all good, relay seems fine, idk what else to do??
 

·
Registered
Joined
·
122 Posts
Loose wires?

I had a similar problem in a nissan. The ignition wires were butchered from an alarm installed and removed before I ever got it. A good squeeze or twist of the wire loom at the bad connection it would start right up. Otherwise it was random of starting, no click, no start no turning over, then sometimes it would start. Took the wire loom from ignition and re-soldered and wrapped all the once tapped or spliced and cut connections for the fix.

Check ignition wires and see if there are any bad splices, corrosion at plugs, etc. Could test wires for continuity when it doesn't start to see if there is a break in the system.


Edit: if it turns and cranks and cranks with no start then it isn't the ignition wiring.

"Serious infractions will never expire"
 

·
Registered
Joined
·
1 Posts
I encountered this same problem and it was a very simple fix. In my case the contacts on the starter were fried from trying to crank it so much. Easy fix for only a few dollars.
 

·
Registered
Joined
·
785 Posts
i had a similar issue on my 87 22re as what you mentioned about it cranking and cranking and not turning over. It ended up being the cold start injector. Once it was replaced, it would fire right up every time.
 
1 - 4 of 4 Posts
Top