TTORA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
ok i know that the driver and pass side use diffrent plugs. well i went to the stealership to get some new plugs since im at 30k so i can do the service. the guy at the parts counter tells me i can put the denso plugs on both sides, sounded shady to me since from the factory they come with ngk's on the pass side. but insted of argue with him i just buy them all, i have just installed them against my better judgement and was wondering if i should take them out and replace them with the correct plugs. thanks for any help.
 

·
Registered
Joined
·
72 Posts
My truck was the same way, and I replaced all the plugs with Denso's. I haven't had a problem in over 35K miles since the change. The next sets of Denso’s are patiently waiting to be installed.
 

·
Registered
Joined
·
1,001 Posts
I think their are very few that have replaced their plugs as per the factory. Most either go all Denso or all Ngk. Havent heard any of the normally aspirated trucks having problems this way.

Tim
 

·
Registered
Joined
·
279 Posts
I'm gonna change mine in the next two weeks. I'm getting NGK iridiums from www.clubplug.net. All six with shipping comes out to 45.95, which is the best deal I've found. I looked into Denso's, but the prices I've found are way higher.
 

·
Registered
Joined
·
95 Posts
tufftaco2k4 said:
ok i know that the driver and pass side use diffrent plugs. well i went to the stealership to get some new plugs since im at 30k so i can do the service. the guy at the parts counter tells me i can put the denso plugs on both sides, sounded shady to me since from the factory they come with ngk's on the pass side. but insted of argue with him i just buy them all, i have just installed them against my better judgement and was wondering if i should take them out and replace them with the correct plugs. thanks for any help.

I've always used the same on both sides with no problems. My toyota manual says to replace the plugs with either Denso K16TR11 or NGK BKR5EKB-11 on the 3.4 and says nothing about using one type on a specific side. So you should be fine.
 

·
Registered
Joined
·
95 Posts
this has come up before, of coarse, never with much explanation. i was wondering if it isnt due to the coil packs being on one side of the engine. not that it seems to matter....
 
Joined
·
100 Posts
Just had 7th installed and put in Denso Iridium IK 20 gapped at 0.032. The plugs that came out (original) were ALL Denso K16TR11.
'02 3.4 Pre-Runner S/C, 7th, TRD headers, cat-back, air filter, Summit traction plus helper springs and momomax shocks.
 

·
Banned
Joined
·
598 Posts
wow, you guys use the pricey stuff. i use the 99cent Autolites and change them every 12 months.

and why would the plugs be different on one side of the motor ??
 
1 - 9 of 9 Posts
Top