TTORA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I recently purchased a used supercharger off of craigslist for my 3.4 Tacoma. The supercharger came with the TRD 7th injector kit including the TRD piggyback ECU and Junction Box. In the TRD 7th injector wiring instructions and photos there appears to be a red wire coming out of the back of the 31pin connectors that plugs into the TRD 7th injector ECU. In the manual it is labeled as the "Ignition Power Wire" and gets soldered in to the ignition on wire of the factory ECU. This red wire is different than the "pink" wire that comes from the actual 7th injector and goes into the back of the same connector I think? So the red "Ignition Power Wire" seems to be missing from my harness and I am hoping someone out there that is running this setup, or has the TRD wiring connectors laying around can look at the pin spot that the red wire comes out of and let me know where I should insert a new red wire. Where I have drawn the white arrow with the question mark is the A2 pin that I think actually is used by the "pink" wire, but I saw the remnants of a wire connector in that spot so I wasn't sure.

Thanks
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Whoops, you are absolutely right. The arrow I drew in is pointing to A8. I still have the same issue/question of not knowing which pin the red "Ignition Power wire" should go into. The TRD installation instructions have you put the 3 wires from the 7th injector Pink, Black, Black w/red stripe into A2,A6,A7 respectively, but because the Red ignition power wire was installed from the factory there are no instructions as to which pin it should be in if it is missing/removed.

Any help from someone with one of these TRD 7th injector wiring harnesses would be much appreciated. I have looked everywhere for info or a better picture of the plug connectors than is given in the installation instructions.

Thanks
 
1 - 3 of 3 Posts
Top