TTORA Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
268 Posts
Discussion Starter #1
Hey everyone,
I have had a 98' Limited Tacoma since I was 15, recently got it the TRD Supercharger, headers and before that gave it full armor. I've had my ABS light on for what feels like forever, The controller module under my hood is supposedly bad. I've been having the worst time finding one. Does anyone have advice or any knowledge on the topic? I'm tired of totalling cars while skidding towards them with no ABS lol

Toyota says they dont have any and i havent seen any on eBay.
61778
 

·
Registered
Joined
·
268 Posts
Discussion Starter #2
61779
61780
 

·
Administrator
95.5 Tacoma
Joined
·
18,463 Posts
You can check Car-part.com and maybe specialized Toyota junkyards for the part. That is a safety component that is commonly damaged in front end collisions, so I'm sure that not helping with part supply.
 

·
Registered
Joined
·
34 Posts
Toyota's go to is the ABS controller because every problem code states "something blah blah or ABS ECU". Like "low battery voltage or ECU". Like duh... I illiterately reset mine and it was fine for 2 months until I tore the front end a part for repairs.

You should run the diags in the FSM first (google). Mine is a 2K so it's a bit different but, you probably need need a jumper to pull the codes, then reset everything first.

Read the code (assuming it's there on a '98).
Clean all your sensors, make sure they are plugged in.

If all else fails there are these guys on ebay. I have ZERO experience with them and this is NOT and ENDORSEMENT.

Best of luck
 

·
Registered
Joined
·
208 Posts
Hey everyone,
I have had a 98' Limited Tacoma since I was 15, recently got it the TRD Supercharger, headers and before that gave it full armor. I've had my ABS light on for what feels like forever, The controller module under my hood is supposedly bad. I've been having the worst time finding one. Does anyone have advice or any knowledge on the topic? I'm tired of totalling cars while skidding towards them with no ABS lol

Toyota says they dont have any and i havent seen any on eBay.
View attachment 61778
I have had the same issue with my 2002, in 2015 I had the Stealer find the problem, the ABS had been out since 2009. Turns out the wire harness at the wheel (R/F, L/F & R/R) was damaged, most likely from Off-Roading, they fixed it but it's a hard thing to trace, they actually re-wired it to make it work.
 

·
Registered
Joined
·
28 Posts
FWIW, on my '03 and '04 there's an ABS wheel sensor cable connector on the driver side frame in front of shock that seems to get funked up about half the times I get an oil change. The wire gets pulled out of the connector or the connection gets flakey. Likely the wire is getting caught when they're removing the oil filter. Check this connector (and other sensor connectors). Give the wire going into the connector a light tug. If the wire comes out, you may be able to take the connector apart and plug the wire back into the seal on the connector shell. This has worked for me so far. Much cheaper than replacing stuff.
 

·
Registered
Joined
·
1,555 Posts
My ABS light has been on for several years now. I haven't taken it in to have it diagnosed, hoping it would be something I could figure out and repair....hasn't happened yet....SRS is another light that popped on one day and still need to diagnose.
 

·
Registered
Joined
·
16 Posts
check the wires going to the right front under the kick panel theatres where mine was bad. Take two long wires and a multi meter and check continuity in just the harness from each wheel to the controller and I bet you find your prob.
 

·
Registered
Joined
·
208 Posts
My ABS light has been on for several years now. I haven't taken it in to have it diagnosed, hoping it would be something I could figure out and repair....hasn't happened yet....SRS is another light that popped on one day and still need to diagnose.
I had mine checked at the dealer in Santa Barbara; turns out they have a top-notch mechanic that found the ABS Wire Harness was damaged torn from off-roading in the right front and left rear, this was expensive to trace out. But fixed for now.
 

·
Registered
Joined
·
1,555 Posts
I had mine checked at the dealer in Santa Barbara; turns out they have a top-notch mechanic that found the ABS Wire Harness was damaged torn from off-roading in the right front and left rear, this was expensive to trace out. But fixed for now.
I bet it was expensive, dealer service rates are extremely high in some(most) places. What they found to be the problem with yours should be visible if I were to have a similar problem?
 

·
Registered
Joined
·
208 Posts
I bet it was expensive, dealer service rates are extremely high in some(most) places. What they found to be the problem with yours should be visible if I were to have a similar problem?
Not really, they said it was an electrical trace that was broken.
 
1 - 12 of 12 Posts
Top