TTORA Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
part no. 8946735060 $244. Need help please. This is causing a check engine lite to come on and no reset of the computer is working. I'm told it regulates gas/air at startup when the engine is cold. I'm also told it cost $130 to install. Ouch. and with only 47K miles I'm not reall happy about it. bty it's an O2 V6 dbl cab prerunner. If I can find it and confirm it's the real cause I'll change it myself if it's not to difficult. Any comments?
 

·
Registered
Joined
·
1,472 Posts
Whats the code for the CEL?
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
actually sent them an email today but no repsponse yet. went to the stealer today and confirmed at least the part number, the location and the cost. heck even ordered it just in case. my only concern at this point is, if the code is wrong and I replace the part then what. for what they want to charge of a diag. I can buy a reader (one recommended by the service tech and cost less then what they want to charge) double check it and then go ahead and replace, reset and hope I've got it right. If you know of anyone I should contact direct at URD, please shoot me the info and I'll do so tomorrow.
 

·
Registered
Joined
·
1,216 Posts
If you want a sensor, you can just place your order online.

Now did the dealer really do a diagnostic or just pull a code? The code does not tell the mechanic what is wrong. The code only recommends what diagnostic proceedure to run to find out what is wrong. Did they run the proceedure to deternine the air/fuel ration sensor is bad or did they just pull a code?
 

·
Registered
Joined
·
58 Posts
Discussion Starter #8 (Edited)
I got the code from using a non dealer code reader, spoke directly with the night service manager at my favorite local dealer and with all infoI had they were pretty certain that was the cause. I ordered the replacement from urd today. I forgot the guys name from urd but he mentioned you so I knew when he called me I was all set.
 

·
Registered
Joined
·
17 Posts
If I remember correctly, O2's are 3yr/36k mi. and I had heard that a lot of Tundra owners with the '02 had many problems with the heater circuit going out, which is what your code is suggesting.

Scott
 

·
Registered
Joined
·
58 Posts
Discussion Starter #10
Well thanks to Gadget, Brian from URD, and others I'm back to normal operations. My 02 Tacoma had the check engine lite come on and after stopping by the local AutoZone to get the code read, and with a little confirmation via the Toyota Service tech, I purchased a new Air Fuel Ratio Sensor aka oxygen sensor from URD for $34 dollars cheaper than I could find it anywhere else, and after 15 minutes (removing two nuts and one connection, the old one is out and the new one in, my dash is clear of any check engine lite. I did disconnect the neg just to make sure and then ran the truck for about 5 min to confirm. Mind you the dealer wanted $130 in labor, $244 for the part and there would have been tax and time on top of that. So once again it's proof that TTORA and it's member's know they're stuff.

Thanks again for all the assistance.
 

·
Registered
Joined
·
503 Posts
TXTACO said:
part no. 8946735060 $244. Need help please. This is causing a check engine lite to come on and no reset of the computer is working. I'm told it regulates gas/air at startup when the engine is cold. I'm also told it cost $130 to install. Ouch. and with only 47K miles I'm not reall happy about it. bty it's an O2 V6 dbl cab prerunner. If I can find it and confirm it's the real cause I'll change it myself if it's not to difficult. Any comments?
Should be covered by your power trin warranty.

Chris
 

·
Registered
Joined
·
3,596 Posts
I believe that your O2 sensors are covered by the 60,000 mile warranty and if not then I think toyota has an emissions warranty that lasts even longer??
 

·
Registered
Joined
·
33 Posts
nope

Those sensors are 3/50000, according to the local dealer, warranty manual says that sensors are not included in emissions warranty. That is crap IMO. Oh well just replaced mine at 53k. The truck runs great now, but cel came back on.
 

·
Registered
Joined
·
908 Posts
if you have 47K miles aren't you still under warrantee?
old thread I know just an fyi


8yrs 80k miles federally mandated warranty on any vehicles emissions related parts from cat to sensors etc.

don't let them fool you
 
1 - 14 of 14 Posts
Top