TTORA Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
402 Posts
Discussion Starter · #1 ·
I have a 95 tacoma that had never been wrecked or abused whatsoever. Therefore the airbag has never been deployed. But, for some reason here lately, sometimes, but not everytime, when i drive my truck the airbag light stays on. I don't know why it does it, and its not on all the time. ANy ideas?
 

·
Registered
Joined
·
402 Posts
Discussion Starter · #3 ·
Yes i actually had a radio put in a couple of weeks ago and that's when it started. ANything i can do to fix it?
 

·
Retired
Joined
·
4,641 Posts
Yes i actually had a radio put in a couple of weeks ago and that's when it started. ANything i can do to fix it?
You had a radio put in, as in someone else did it for you?

The passenger airbag switch has a couple of connectors that need to be unplugged to get the center dash off so it's likely that a connector was not plugged back in; I had the same thing happen when I did some stereo work.
 

·
Registered
Joined
·
402 Posts
Discussion Starter · #5 ·
well i had it put in, but i opened it backup a few days later to wire up an amp and everything, so i may have unplugged something. For some reason i didn't think my truck had a passenger airbag.
 

·
Retired
Joined
·
4,641 Posts
well i had it put in, but i opened it backup a few days later to wire up an amp and everything, so i may have unplugged something. For some reason i didn't think my truck had a passenger airbag.
I've never been inside a first-gen Taco so I don't know if they have passenger airbags, but mine has a switch on the top-left of the center dash that turns off the passenger side airbag.

Any harnesses with yellow tape or connectors are airbag related.
 

·
Registered
Joined
·
1,183 Posts
be careful with that plug. i have heard that it is really expensive to replace. from what I remember, it was too expensive for me to justify fixing it, so i just left it broken
 

·
Registered
Joined
·
1,562 Posts
well i had it put in, but i opened it backup a few days later to wire up an amp and everything, so i may have unplugged something. For some reason i didn't think my truck had a passenger airbag.

Nope...first gen tacos don't have passenger airbags. Most likely the wiring harness on the airbag controller is just loose. Be VERY careful when messing with the airbag wiring. Its always a good idea to disconnect the battery and leave it disconnected for 20 minutes or so before messing with the wiring harness.
 

·
Registered
Joined
·
1,657 Posts
same issue here. the stupid light comes on and off like crazy.

still a mistery too me...:rolleyes:
 
1 - 10 of 10 Posts
Top