TTORA Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
260 Posts
Discussion Starter #1
Was driving home tonight and the "battery" light came on in the dash. Not sure if its the battery or the alternator. I've got a diehard platinum for a battery that's a couple years old. The alternator is stock so I'd assume that's what went gunny bag. Any suggestions?
 

·
Registered
Joined
·
650 Posts
LOL... mine came on yesterday. 271k miles on my '97. Did battery and starter last month... today it got a new alternator. 99% of the time if you see that battery light it's the alternator I'm told.
 

·
Registered
Joined
·
260 Posts
Discussion Starter #3
Cool. That's what I was pretty much thinking. Wasn't really looking at dumping the cash on a new one but oh well. I guess I can't complain with as long as it lasted. Lol
 

·
Registered
Joined
·
3,205 Posts
When mine goes I'm considering one with higher output for a replacement.
 

·
Administrator
Joined
·
18,233 Posts
I've had the original alternator on my truck for the last 310k miles. Only problem I had was the front bearing went out around 150k. So I bought the bearing and replaced it. Been working fine ever since.

The typical problem when the light comes on is that the alternator isn't charging the battery and lots of times this is because the brushes are stuck due to mud. If you hit the mud a lot, this can happen. If you pull the alternator, remove the rear cover and clean out the brushes and the contacts, it will probably work just fine.
 

·
Registered
Joined
·
260 Posts
Discussion Starter #6
Thanks for the info. I figured I'd go ahead and order the bearings, a brush kit, and stuff. Figure if I got to pull it off I'll just rebuild it. Dealership wants almost as much as the high output ones online.
 
1 - 7 of 7 Posts
Top