TTORA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter #1
My brakes were feeling light so i naturally checked the brake fluid and it was low. I filled the fluid. Now, when i pump the brakes i feel pressure build up, but as soon as i take my foot off the brake and hit the gas then try to brake again, the pedal hits the floor.

I'm pretty sure i have a bigger issue but wanted to see if you guys had any ideas. I found a leak on the passenger side line but i think my problems may lie deeper...

any ideas?
 

·
Registered
Joined
·
4,294 Posts
Did you bleed your barakes? What LT kit do you have up front?
 

·
Registered
Joined
·
312 Posts
Discussion Starter #3
Total Chaos, same as yours i believe.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #4
I used a brand new can, but i guess air can still get in. I haven't had to bleed them before, but ill try it.
 

·
Registered
Joined
·
4,294 Posts
Yeah your problem sounds a lot like what happened to me about a week ago. Check your banjo bolt where the brake line ties into the caliper and see if it looks fucked up. either my LCA or the bottom of the coilover hit mine and caused it to strip out the caliper...the brakes would build pressure but then it wouldnt sustain it.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #6
Gotcha. I don't have any tools or jack stands where i'm at so i'll have to wait. Thanks for the advice Derek.
 

·
Registered
Joined
·
4,294 Posts
Are you in Ventura right now? I'm about to leave SLO to head back down to SoCal so i'll be passing through in about an hour and a half or so.
 

·
Registered
Joined
·
312 Posts
Discussion Starter #8
I'm in Newbury Park right now. Where are you going?
 
1 - 8 of 8 Posts
Top