TTORA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
ok i was driving one night late and my passenger headlight went out then 2 nights after this happened my diver side headlight went out so i had to drive with brights on but when the lights were dead in low beam i was in high beam and the high beam light on the dash wouldnt come on i am about to get new lights i checked the fuse box nothing would anything be wrong? so if there is anything wrong can you guys inform me i dont want to spend 100$ and and blow them also












halingen silver stars
 

·
Registered
Joined
·
1,329 Posts
were you in high beam mode or flash to pass? are the filiments damaged in the bulb? its possible your bulbs jsut decided to die.... wtf?! kind of headlights are you buying that are $100
 

·
Registered
Joined
·
1,730 Posts
I've heard of halogen bulbs burning out very quickly when put into a vehicle that wasn't originally setup for them. I believe it has to do with the operating specs of the OEM non-halogen lights and wiring harness/plug vs what the recommended output of the halogens should be.

I'm by no means an expert on this subject, but I definitely read about this somewhere a few months ago. Your bulbs might just be burning out faster because of that electrical output difference of the bulb wiring setup. If the extra light is worth the huge price jump of the bulbs plus the shorter replacement interval, stick with the halogens(and maybe even consider modding your bulb wiring harness with one setup for Halogens).. but if not, you could always go back to OEM spec bulbs.
 

·
Registered
Joined
·
2,364 Posts
IMO,it's not uncommon for the other bulb to burn out quickly when the other light is out. It also may have been the way you installed them. You should not handle them with bare hands. The oil in your skin causes the bulb to burn out prematurely.:2cents:
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
ok i went to shucks and bought a new pair and i just installed them and yes i know your not supose to man handle them and i didnt but i just put in the new ones and yes they work and when i put on the high beams the light does come on, on the dash so the problem is solved thanks
 

·
Registered
Joined
·
2,364 Posts
good deal bud! Glad it worked out for ya.
 
1 - 6 of 6 Posts
Top