TTORA Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
This canister by the wiper motor buzzes for about 10 minutes after I shut the motor ( V6 ) off. Also, the tranny ( Auto ) has been acting up a bit lately. As it goes from first to second at low speeds, it seems to shift O.K. and then it kind skips it too soon and goes to third and dogs the motor. I usually have to hand shift it back to 2nd to correctly use the motor, which runs great. I have tried it with the tranny mode button in both positions, power and normal and it does the same thing.

This is on an 89 Runner.

Which I am planning to sell by the way. I figure about $1,500 with great condition one year old 31 inch BFG AT's. on it. It also has new shocks and an add-a leaf in the back.

Body=230,000 miles. Motor 115,000 miles. A bit of rust on the fenders and a host of cosmetic and amenity issues ( the rear window sticks but does roll up, niether of the side windows roll up or down they are all power ). The power steering pump leaks, it needs to be replaced. And something is now draining the electrical since I have to unplug the battery cable if it sits for more than three days. It usually does since I work out of my house in a small ski town that is only 2 miles across and has free buses.

Any ideas on the Runner? I would like to address these within reason before I sell it. I am selling it by the way to upgrade to a 2005 Taco access cab, V6, 6 Spd, 4x4, TRD. First "New" vehicle in 15 years.

Thanks!

T_L
 

·
Registered
Joined
·
16 Posts
the canister is for fuel vapor, usually called the charcoal canister. sometimes one of the lines will plug up and you need to blow them out. get a manual and it will tell you the steps in testing and repairing.
 
1 - 2 of 2 Posts
Top