TTORA Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
292 Posts
Discussion Starter · #1 ·
My truck just threw a code at me. It was either P0420, P0421, or P0422. I'm not sure because the guy at autozone just showed me the description in the book and didn't write down which of the three it was.

Anyway, all three codes amount to a catalytic converter going tits up. Problem I've got, that cat is only 6 months old.

My truck is a 2.7L manual, with no engine mods. I put a deckplate with a TRD filter, an LCE header in 2.25", LCE hi-flow cat at 2.25" and 2.25" cat-back with the 16" Xcelerator muffler. All these mods were done, at the same time, last september. No problems since.

Did I finally just piss off the oxygen sensor, or did I really manage to burn through a cat in 6 months with a stock engine? How do I go about figuring out what's really wrong? Or should I just reset the code and hope for the best.

And btw, not losing a drop of oil in 5k miles, so I can't have fouled the cat that way.
 

·
Registered
Joined
·
13 Posts
I had the same problem with my 02' I took off the 2 cats that came stock and put one hi-flow on it and a v-force exhaust. I dont know if it really helped with anything or not but my truck gets one of those error codes also. It doesnt seem to run any differently wich is ok by me. It comes on and goes off as it pleases. So I would say you just pissed of the 02 sensor gods
 

·
Registered
Joined
·
269 Posts
If you have an O2 sensor behind the cats you will turn the CEL light on if both cats are not there. Something to do with burning all the gases properly. Personally I think it is a bunch of BS. I am running a "test Pipe" in my truck. To avoid the CEL coming on I installed an O2 sensor eliminator from URD. It was worked great for about a year now. LOL. Still have the "test pipe" in. Mechanic said i should maybe leave it in there for a longer test. Good thing he is a good friend of mine. Here is the link.

http://www.urdusa.com/product_info.php?cPath=66_72&products_id=1230100014

Just a thought. Check though to make sure you have an O2 behind your cat before you buy this. WIll not do you crap if you dont.
 

·
Registered
Joined
·
292 Posts
Discussion Starter · #4 ·
I should have said that my truck is not california legal to start with, it only had the single cat when it was still stock.

I was hoping to avoid the O2 sim, but I'll look into it.
 

·
Registered
Joined
·
5,490 Posts
I have no catalytic converters, with the URD o2 simulator, and every once in a while I'll throw CEL code P0420, so I bet that's the code you were throwing, and if that's the case you probably need a new cat.
 

·
Registered
Joined
·
34 Posts
try tightening your gas cap. Usually codes P0420thru P0422 I think are evap codes(emission ,etc) yeah, it could be your O2 sensors, but if the code scanner detected a small leak, chances are it could be the gas cap not being on all the way, turn it til it clicks three times.
 

·
Registered
Joined
·
269 Posts
Jamie. You still get codes about the O2? I havent since I put it on and I do not have any cats on it at all. Oh well.
 

·
Registered
Joined
·
5,490 Posts
Yeah - every couple of months I'll pop P0420
 

·
Administrator
95.5 Tacoma
Joined
·
18,585 Posts
Check for exhaust leaks. Also, since your cat is removable, drop it out and look and see if the honeycomb is still in good condition. After that, test your O2 sensors to make sure they are working properly.

If you took the time to look at the online FSM, there are procedures for troubleshooting the P0420 codes which pretty much cover what I just said.
 
1 - 9 of 9 Posts
Top