TTORA Forum banner

1 - 7 of 7 Posts

·
always a Toyota lover at heart
Joined
·
1,114 Posts
Discussion Starter #1
I had a low level of Auto-transmission fluid in my 1998 tacoma today, I drian and filled it with 4 Quarts.

I had a CEL come on and I read the code:
P1780, I asked a Toy tech(mechanic) and he said it was the Neutral/Park switch
Has anyone had this happen to them and what was done to remedy the situation?
 

·
Administrator
95.5 Tacoma
Joined
·
18,503 Posts
The manual says this will happen if shifter shows N and you speed is more then 45mph for more then 30sec and the engine is 1500-2500rpm or if 2 or more switches are ON in R, N, 2 or L position. Procedure is to verify switches are working properly and no short is detected. Did you start by checking to see if you have a loose connection?
 

·
always a Toyota lover at heart
Joined
·
1,114 Posts
Discussion Starter #4
ShowStop said:
The manual says this will happen if shifter shows N and you speed is more then 45mph for more then 30sec and the engine is 1500-2500rpm or if 2 or more switches are ON in R, N, 2 or L position. Procedure is to verify switches are working properly and no short is detected. Did you start by checking to see if you have a loose connection?
Thanks
I have a spare auto-tranny for my trck that I bought some years ago
I can reove the bad switch, I just don't know how to troubleshoot the switch and verify that it is faulty

I think you pegged the problem perfectly, but the problem ended as soon as I drained and added the new fluid.
I erased the code and figured that it may come back soon.
Are you a tech or have experience with auto-transmissions?
 

·
always a Toyota lover at heart
Joined
·
1,114 Posts
Discussion Starter #5
The transmission shop I went to was able to replace the PRN saftey switch and I got it back today!!!
All is good!!!
they even installed my new fuel filter for me!!!
 
1 - 7 of 7 Posts
Top