TTORA Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,816 Posts
Discussion Starter #1
I went down to my hunting property and drove around a bit and everything was working, but i ran over a stick and it got caught up under the front right tire for a few seconds. Afterwards i did a couple of little burnouts on grass and dirt while in second gear. A few minutes after that i noticed that the speedometer wasnt working and the check engine light was on. I didnt notice anything that sounded strange and i looked at the undercarriage and didnt see anything wrong, so i went ahead and did the 1.5 hour ride home and still didnt notice anything wrong. the light is still on and the speedometer still isnt working though. does anybody know what could be wrong?? Thanks
 

·
Registered
Joined
·
1,844 Posts
I went down to my hunting property and drove around a bit and everything was working, but i ran over a stick and it got caught up under the front right tire for a few seconds. Afterwards i did a couple of little burnouts on grass and dirt while in second gear. A few minutes after that i noticed that the speedometer wasnt working and the check engine light was on. I didnt notice anything that sounded strange and i looked at the undercarriage and didnt see anything wrong, so i went ahead and did the 1.5 hour ride home and still didnt notice anything wrong. the light is still on and the speedometer still isnt working though. does anybody know what could be wrong?? Thanks
go down to Napa, Kragen, Shucks, somewhere like that and get it scanned for free, that will tell ya a lot more....
 

·
Registered
Joined
·
204 Posts
probably disconnected the plug on the transfer case. it controls the speedo and if unhooked it will throw a CEL.
 

·
Registered
Joined
·
2,030 Posts
probably disconnected the plug on the transfer case. it controls the speedo and if unhooked it will throw a CEL.
The prerunner doesn't have a tranfer case! You stated you got something in the front right. Maybe the ABS speed sensor cable? I believe the Speedo pickup is on the left side of the tranny? When you get the trouble code checked, go to this site to tell you what it might be:
http://www.ncttora.com/fsm/2003/Repair_Manual/03tacoma/di/ata340ea/dtcc.pdf
Good for auto trans
Engine trouble codes:
http://www.ncttora.com/fsm/2003/Repair_Manual/03tacoma/di/eg5vzfe/dtcc.pdf
 

·
Registered
Joined
·
1,816 Posts
Discussion Starter #7
ok im goin to check for the sensor

also, i just realized that the odometer isnt working either
 

·
Registered
Joined
·
1,816 Posts
Discussion Starter #8
i made sure everything was plugged in all the way and the speedometer and odometer are now working....but the CEL is still on.anybody know why??
 

·
Registered
Joined
·
5,467 Posts
i made sure everything was plugged in all the way and the speedometer and odometer are now working....but the CEL is still on.anybody know why??
Should go away shortly. If not, shut the truck off and disconnect the battery for a few mins. This will clear the code.

If the light comes back on after that, take it to your local auto parts store and have them run a the code scanner on it.
 

·
Registered
Joined
·
1,816 Posts
Discussion Starter #10
becasue you threw a code....duh
o..ok...thanks..im dont have much technical automotive sense..but im slowly learnin

Should go away shortly. If not, shut the truck off and disconnect the battery for a few mins. This will clear the code.

If the light comes back on after that, take it to your local auto parts store and have them run a the code scanner on it.
ok..ill do that....thanks for helpin
 

·
Registered
Joined
·
506 Posts
Should go away shortly. If not, shut the truck off and disconnect the battery for a few mins. This will clear the code.

If the light comes back on after that, take it to your local auto parts store and have them run a the code scanner on it.
On an OBD2 vehicle, the code shouldn't reset from just pulling the battery for a few minutes. The codes can reset after so many starts or other "cycles" but the easiest way is to get a free code scan/clear.
 

·
Registered
Joined
·
3,527 Posts
The codes can reset after so many starts or other "cycles" but the easiest way is to get a free code scan/clear.
Auto Zone, or Pep Boys, or Napa, or wherever can do it for free.
 
1 - 14 of 14 Posts
Top