TTORA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
390 Posts
Discussion Starter #1
I've got a 95 4x4 V6 taco with 140,000 and when I floor it on the highway I'm hearing a ticking noise. It's almost like a valve noise but I just asjusted those not too long ago. When I rev the engine in park I don't get the noise. I was thinking maybe an exhaust manifold leak??? Not real sure what to think. Any sugg's?
 

·
Registered
Joined
·
261 Posts
My 2003 v6 auto does the same thing.It has since about 10k and i am at 26k now. Was told by dealer it is normal. They said injector solenoids or what not and told me not to worry. Since then I have learned to live with it since the engine is still strong as new and the oil is clear of anything when changed(made dealer do a check for me). Same thing for me won't do it in park just under load and in neighborhoods coming back off the curbs it makes me want to grind my teeth. Had it tested for a exhaust leak too and none found. Maybe there is a small leak near the manifold gaskets or something causing this but it should get fixed if there is one there when i finally get headers. I was hoping it would stop after the valve adjustment if that was where the noise was coming from but i think i am still a ways away from that maintenance. You are not alone

Sam
 

·
Smoked Out!
Joined
·
1,869 Posts
WILD YOTE said:
I've got a 95 4x4 V6 taco with 140,000 and when I floor it on the highway I'm hearing a ticking noise. It's almost like a valve noise but I just asjusted those not too long ago. When I rev the engine in park I don't get the noise. I was thinking maybe an exhaust manifold leak??? Not real sure what to think. Any sugg's?
Sounds like ping/knock. Try a higher grade octane rated gasoline.
 

·
Smoked Out!
Joined
·
1,869 Posts
samsc03 said:
My 2003 v6 auto does the same thing.It has since about 10k and i am at 26k now. Was told by dealer it is normal. They said injector solenoids or what not and told me not to worry. Since then I have learned to live with it since the engine is still strong as new and the oil is clear of anything when changed(made dealer do a check for me). Same thing for me won't do it in park just under load and in neighborhoods coming back off the curbs it makes me want to grind my teeth. Had it tested for a exhaust leak too and none found. Maybe there is a small leak near the manifold gaskets or something causing this but it should get fixed if there is one there when i finally get headers. I was hoping it would stop after the valve adjustment if that was where the noise was coming from but i think i am still a ways away from that maintenance. You are not alone

Sam
From your descrition and his, they may be 2 different issues. His sounds more like engine knock while yours sounds more like what you said an exhaust/air leak. Since you are SCed I assume you are using 91+ octain already, and you have gotten your truck tuned to a certain extent. If it is engine pinging it may go away when you get the AIC from URD.
 

·
Registered
Joined
·
261 Posts
Always have used premium fuel in my truck.I can get 93 octane here and I always get Amoco too which as always been the best in my opinion. I have had it tuned with the FTC when it was hooked up and it still made that noise. The FTC is not currently wired in. It is ready to be with all the wiring right next to the ecu and all. Had to unhook it when i had a nagging CE light problem that got fixed(cracked vapor line o-ring or sumthin). I do not think it is ping cuz the tuners told me they rode around in the strip mall with the doors open and the shifter cover off and they do not call it ping. The truck runs really rich too. I definitely will get the tune right when i get the AIC and wideband from URD and maybe i can get Gadget to help with it since i am fairly close.

Sam
 

·
Registered
Joined
·
390 Posts
Discussion Starter #6
I had some headwork done and reused the exhaust manifold gasket b/c it looked to be in good shape. Guess it wasn't...
 

·
Registered
Joined
·
53 Posts
toyota was forced by the bbb to give me a new truck for what you just described, it was nothing but it drove me nuts, they tried 9 times to fix it but couldn't and told me live with it, they lost.
 

·
Going John Galt
Joined
·
31,845 Posts
tnracing132 said:
toyota was forced by the bbb to give me a new truck for what you just described, it was nothing but it drove me nuts, they tried 9 times to fix it but couldn't and told me live with it, they lost.
I'm surprised your new one doesn't do the same, LOL
 
1 - 9 of 9 Posts
Top