TTORA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,452 Posts
Discussion Starter #1
Posted in delphi:

Lately I've been noticing a grinding noise comming from the front driver's side wheel. At first I thought it was only happening with the brakes, but now it happens all the time except at full turn, and every once in a while it will silence for a minute. On my jeep it would have sounded like hub bearings, but I still dont know anything about the taco - so anyone know what this is? I usually do all my own work, so I dont want to take it to a shop, and finals are right around the corner so I dont really have time to open it up and check things out, just barely enough time to throw some money at it and get it working again for the 1200 mile trip home here in 2 weeks.
Thanks in advance for the replies.

Forgot to include that its a '98 Turd, not that it matters. All I'm really saying is that I dont know chit about IFS and was wondering what the equivalent to hub bearings would be on the Toy (maybe they are hub bearings?). It's nothing real bad, thought it was the brake's rubbing at first, but it does it without applying the brakes, which points me to hub bearings, or the like.
:newbie:
 

·
Registered
Joined
·
1,020 Posts
jack it up, grab the tire at a 12 and 6 o clock move it up and down to check bearings. other than that check calipers lower bj, and cvs
 

·
Registered
Joined
·
1,257 Posts
AggieTaco said:
Posted in delphi:

Lately I've been noticing a grinding noise comming from the front driver's side wheel. At first I thought it was only happening with the brakes, but now it happens all the time except at full turn, and every once in a while it will silence for a minute. On my jeep it would have sounded like hub bearings, but I still dont know anything about the taco - so anyone know what this is? I usually do all my own work, so I dont want to take it to a shop, and finals are right around the corner so I dont really have time to open it up and check things out, just barely enough time to throw some money at it and get it working again for the 1200 mile trip home here in 2 weeks.
Thanks in advance for the replies.

Forgot to include that its a '98 Turd, not that it matters. All I'm really saying is that I dont know chit about IFS and was wondering what the equivalent to hub bearings would be on the Toy (maybe they are hub bearings?). It's nothing real bad, thought it was the brake's rubbing at first, but it does it without applying the brakes, which points me to hub bearings, or the like.
:newbie:
Sounds like the ding dong got left in the dohicky. :)
 

·
Registered
Joined
·
436 Posts
yepp sounds like a wheel bearing to me as well... like the other guy said, check for play at 12 and 6. mine didnt start making noise till it got rather loose, so it should be easily identifiable if thats the problem.... good luck!
 

·
Registered
Joined
·
1,349 Posts
definatly check the wheel bearings, if you can find an entire spindle its about a 15 min job if and your finished plus you dont have to worry about pressing the bearings and all that crap. once the noise starts you dont have long untill they decide to go....
 

·
Registered
Joined
·
1,452 Posts
Discussion Starter #7
I checked out the truck today when I took a break from hitting the books for 13 hours straight (got to love finals) and I couldnt find any play in the bearings. I took the tire off to examine the brakes and I didnt see anything abnormal, but there was a slight squeeling when I turned the hub. So I'm pretty sure it's just time for new brakes. Any thing else it could be before I drop the $$ on parts.

BTW, appreciate all the help guys.
 

·
Registered
Joined
·
67 Posts
AggieTaco said:
I checked out the truck today when I took a break from hitting the books for 13 hours straight (got to love finals) and I couldnt find any play in the bearings. I took the tire off to examine the brakes and I didnt see anything abnormal, but there was a slight squeeling when I turned the hub. So I'm pretty sure it's just time for new brakes. Any thing else it could be before I drop the $$ on parts.

BTW, appreciate all the help guys.
Make sure the backing plate isn't rubbing on the rotor and that there isn't something stuck between the rotor and plate.
 
1 - 8 of 8 Posts
Top