TTORA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,396 Posts
Discussion Starter · #1 ·
I've got a new noise/"vibration" in the front end of my truck.

'98 Taco 4x4 - manual hubs
Lifted about 2.5" in the front right now.

The Problem:
Only while slowing down, under about 5-8mph.
"Thump" noise, happens usually 2-4 times before coming to a stop.
Can feel it in the floorboard if I place me foot flat under the clutch.
Feels almost like when you're got a lump on a bald tire.
Occurs regardless of gear/neutral, 4x2/4x4, hubs unlocked/locked.
Seems to be tire RPM dependent.

My thoughts:
I'm at school now, but plan on checking what I can here, then more at home in about a week and a half. Please add to the list if you have any other thoughts.

1) Ball Joints
2) Tires/Rims
3) Brakes (rotors, calipers, pads)
4) Coilovers
5) Steering?
6) Hubs? (could probably stand to be rebuilt anyways)
 

·
Registered
Joined
·
20 Posts
I have something very similar happening and am going to put Donahoe coilovers on very soon. When I pull the front end apart I'm sure I'll find out what the knock is. Mine feels like it has something to do with the suspension.
 

·
Registered
Joined
·
1,396 Posts
Discussion Starter · #3 ·
I have something very similar happening and am going to put Donahoe coilovers on very soon. When I pull the front end apart I'm sure I'll find out what the knock is. Mine feels like it has something to do with the suspension.
I've got Fabtech COs on there, I suppose I could rebuild that strut and see.
 
1 - 3 of 3 Posts
Top