TTORA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
so fat i'm not impressed, it was awesome at first, although a little stiff. i blamed that on having a 4cyl instead of a v6. but after about 8 months i blew a rear shock. replaced both. everything was awesome in northern arizona great setup smooth in the dirt and rocks no real issues...yet. after a summer in AZ i went back east, this is where my problems started. the threads in the upper mounts for the front have rotted out due to dissimilar metals (steel bolts in an aluminum mount) i found this out when i went to replace the front shocks...which i cant do without replacing the whole set up. after having this setup on my truck ive been telling people to save more an go in a different direction. i loved my toytec lift...when it was new...now, not so much. i have the shocks...ready to go in...and cant replace them, now i'm saving up to go in a different direction...

very disappointed.

i'm not that hard on my truck, i dont even use 4hi, if i'm in the dirt i put it in low, the lil 4cyl is just happier that way. i dont go 'hardcore' on the trails cause i dont like dumping money into my truck wastefully. now i have to because i cant even do a simple repair cause the mount have rotted out.

toytec, please consider converting to a STEEL upper mount on the front... yes the manufacturing and materials cost more. but it would seriously increase the longevity of the kit.

for now...its time to :saw:
 

·
Registered
Joined
·
1,803 Posts
This is a little sad to hear. I'm hoping your problem was just a freak accident but multiple things happening to you... :(
Do you wheel your truck hard or something?
 

·
Registered
Joined
·
508 Posts
I know i'm a little late to respond but please give me a call and we will get you taken care of.

My number is 303-255-4959 ext 103

-Dylan
 
1 - 3 of 3 Posts
Top