TTORA Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
As most of you know I wreaked my truck and got it back a few weeks ago and now the truck is making noise and i dont know what to do..HELP!

Sounds like a bearing has gone bad, Kinda traced it out and it sounded like the altinator, so I just replaced that and still have the noise..

I also took off all of the belts, power steering, and AC. So all that was left was the new altinator which also spins the fan... I still have the noise, its the worst when I start the truck and then kinda comes and goes.

It almost looks like my crank pulley has a slight wobble..

any ideas???
 

·
Registered
Joined
·
2,030 Posts
So all that was left was the new altinator which also spins the fan... I still have the noise, its the worst when I start the truck and then kinda comes and goes.

It almost looks like my crank pulley has a slight wobble..

any ideas???
I would say fan bad? Remember clutch fans on trucks. They do go bad at times?
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #3 ·
I would say fan bad? Remember clutch fans on trucks. They do go bad at times?
Ok, but the fan and clutch are brand new, as is the water pump, and now the Alternator.
 

·
Registered
Joined
·
2,030 Posts
Your beyond my knowledge now. Sorry can help more. Only thing I can think of now, is crank shaft bearing or harmonic balancer?:2cents:
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #5 · (Edited)
Thanks im going to stop by the shop that fixed my truck tommmrow.

btw here are some pix..
 

·
Registered
Joined
·
1,934 Posts
Doenst thie idle pulley go out on these things commonly? I thought that mine was going out... 134 dollars. WTF...
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #7 ·
What idle pully are you talking about? the AC pump or the power steering idle pully? the AC one in new...but I took off all of the belts execpt the new alternator. and I still have the noise...
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #8 ·
bump.
 

·
Registered
Joined
·
370 Posts
.................. I took off all of the belts execpt the new alternator. and I still have the noise...
Is the noise still there without the alt belt?
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #10 ·
Is the noise still there without the alt belt?
No, So thats why im thinking its the water pump maybe, but also when the pullys have a load thats when it makes more noise.

Also could the crank pully been bent from this accident?
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #11 ·
Ok the truck is fixed, as far as the noise goes, I installed the LC Engineering Under Drive pulley, Now no more noise, the truck goes in tomorrow to get a new charcoal canister and air dam....
 
1 - 11 of 11 Posts
Top