TTORA Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
ive had this hesitation for a bit now and i cannot pin point the problem.

99 v6 SC URD 2.2 pulley AT
35 1250
4.88
trd drop in

when i pull out into traffic and try to get up to speed say 3/4-full throttle. it feels like im pulling a boat until i hit about 3k and they the truck pulls really hard. any ideas. ive checked the tune and everything seems in order.

the rpms will rise really slow until it get to around 3k the VROOOM

kinda like shiftin into 2nd too early on a manual. anyway to mess with the shift points. it gets better with the ECT on. but it wasnt always doin this.

Justin
 

·
Registered
Joined
·
5,124 Posts
mine kindof does the same thing. i attribute it to the tune, since i havent gotten it fine tuned yet
 

·
Registered
Joined
·
121 Posts
Discussion Starter #3
i had mine fine tuned when it was on 33s with stock gears. ive since changed to 35 and 4.88 and gadget said that shouldnt effect the tune so who knows. im gonna look into o2 sensors since they are the originals with 103k on them

Justin
 

·
Registered
Joined
·
261 Posts
Hey Justin. Can't help ya with the problem but my truck has an issue that started last friday comin from work. In high gear(o/d) doin about 60-63 mph and hit about 2psi and there is a noise comin from somewhere like a pinging. I took the dash apart on satrurday and drove around after i looked at the FTC boost line to make sure it was ok and it was and it did the same thing with the noise further back. Definitely need to diagnose it as ping or somethin else. Gonna try and contact somebody at URD to see if I can drive up and get a tune and a AIC.See ya round.

Sam
 

·
Registered
Joined
·
146 Posts
I had the same problem. Mine is on a 95 3.4v6
I have changed the fuel pump and filter, a O2 sensor, new plugs and wires and have had my injectors removed and cleaned. Still the same problem. So I took it to the dealer ship and the driver cam is out of time by 2 teeth. I hope this fixes this problem or it goes for sale!
 

·
Registered
Joined
·
92 Posts
I do not have a SC but I did have a hesitation problem for several years. I Replaced the fuel filter, plugs, cleand the MAF sensor and injectors but with not change. Brought it to the dealer twice for a diagnostic before they figured out it was my spark plug wire #1 grounging out. I replaced the whole set of wires and wow what a difference, I got power again! Not sure i this will resolve your issue but it worked for me.
 

·
Registered
Joined
·
121 Posts
Discussion Starter #8
gadget told me that cold weather ill cause the timing graph to drop because the pressure is actually different the the gauge reads. throwing the timing off inducing ping. im gonna meet with some guys in portsmouth (srunner guys) on a weekend soon for a mini tuning session if you wanna meet up. well have a wideband and scan tool and i have a laptop. let me know

Justin
 

·
Registered
Joined
·
121 Posts
Discussion Starter #9
so you say the cam was out of timing. well with the FTC i can adjust that maybe it is just a timing issue.

thanx

Justin
 

·
Registered
Joined
·
5,124 Posts
My68ur8trd said:
so you say the cam was out of timing. well with the FTC i can adjust that maybe it is just a timing issue.

thanx

Justin
if the cam was physically off timing, you cant adjust that with the ftc, youd have to physically line up the cams with the timing belt
 

·
Registered
Joined
·
261 Posts
Offer sounds good let me know when. I am waiting on Gadget to get back with me,I would like for him to take a the first crack at tuning with the AIC. You do not know anyone lookin for a 04 Grand Cherokee Limited do you? Gotta sell my Dad's truck. Give me a call if you think you could help me out.

Sam
 

·
Registered
Joined
·
261 Posts
Hey u met up with Gadget up in Md right?
Do you know how i can get a hold of him? Appreciate it.
 

·
Registered
Joined
·
146 Posts
You would have to remove the front cover so you can see your cam gears. Then turn your crankshaft so the timing mark lines up and then check the timing marks on the cam gear. My problem was that the crank shaft was in time checking it with a timeing light. It looks like it just slipped two teeth. I just replaced this belt about three months ago! But this did fix my problem.
 

·
Registered
Joined
·
1 Posts
So did anyone ever really decide what was causing the problem? Last month my 01 Doublecab hit 90,000 miles, with 200 miles of that my CE light came on and the identical hesitation is happening. Once the RPM's hit about 3200 and the throttle is 1/2 to 3/4 open, the engine/truck feels like there is a power surge.
 
1 - 20 of 30 Posts
Top