TTORA Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just purchased a 97 Ext cab 4x4 Tacoma with the 3.4 v6 and manual 5 speed. I've been driving it daily for a month and I've calculated that I'm getting around 10 mpg!!! I never thought I'd consider driving my 56 Ford pickup to save gas! Anyways I haven't had time to investigate quite yet but I'm planning on getting into it this weekend. I was wondering if anyone could shed some light on the common causes of such horrible mileage? Some more info, the motor has 236k miles but still feels good and strong, and I've been driving it really easy but to no avail. Thanks in advance!

Craig
 

·
Registered
Joined
·
342 Posts
blitzkraig said:
I just purchased a 97 Ext cab 4x4 Tacoma with the 3.4 v6 and manual 5 speed. I've been driving it daily for a month and I've calculated that I'm getting around 10 mpg!!! I never thought I'd consider driving my 56 Ford pickup to save gas! Anyways I haven't had time to investigate quite yet but I'm planning on getting into it this weekend. I was wondering if anyone could shed some light on the common causes of such horrible mileage? Some more info, the motor has 236k miles but still feels good and strong, and I've been driving it really easy but to no avail. Thanks in advance!

Craig
That sucks man, something is wrong. I get about 13-city and 18 highway and thats with a lot of armor and larger tires.
 

·
Registered
Joined
·
176 Posts
Take one dose of a MAF sensor cleaning, throttle body cleaning, fuel filter replacement...and a big serving of SEARCH and check back in the morning.
 

·
Registered
Joined
·
892 Posts
How about the plugs?

How about the plug wires?

How about the fuel filter?

A major maintenance go-over would be good...especially since you just purchased it and you have NO idea what the previous owner did (or lack there of) to it.
 

·
Registered
Joined
·
1,582 Posts
replace replace replace lol plugs, oil, wires, clean clean clean.... Just like they said. You got it used, you pretty much buying somone else's problems. Changed all the fluids just as a precaution? airfilter? maybe look into putting and aftermarket one on. Lots of arguing on here between them lol (AFE, K&N, AirRaid, ect.), Anything to slow your truck's forward momentium down...Thats not good at all, my truck I got now does about 20+ in the town... Think I got blessed with a good one.
 

·
Registered
Joined
·
4 Posts
The 3.4 in my 96 had the same problem when i bought it with 230k. Have you driven a newer truck with less miles and compared the power?I did and the newer truck had way more power than mine so i did a compression check and found out i had lost about 30%. I think the premature failure of the engine was a combination of lots of dirt roads and bad 02 sensor making it run too rich. Anyway get the compression checked if none of the other suggestions work.
 

·
Registered
Joined
·
395 Posts
Yea the first thing to do to any new to you vehicle is to do a tune up and change all the fluids. (Unless you know the PO). Also remember that if you have bigger tires your calculations will be off. (unless you've regeared to make the speedo right.)
 

·
Registered
Joined
·
2,509 Posts
i hope you got a really good price, because your about to spend some serious cash on maintaince!


btw i would do the deckplate mod...afterall its FREE
 

·
Administrator
95.5 Tacoma
Joined
·
18,420 Posts
nemesis said:
Take one dose of a MAF sensor cleaning, throttle body cleaning, fuel filter replacement...and a big serving of SEARCH and check back in the morning.
x2 lol! :lmao:
 

·
Registered
Joined
·
533 Posts
Muddin taco2131 said:
i hope you got a really good price, because your about to spend some serious cash on maintaince!


btw i would do the deckplate mod...afterall its FREE

Free to you, but it will still cost your dad about 15 bucks.
 

·
Administrator
95.5 Tacoma
Joined
·
18,420 Posts
007 said:
Free to you, but it will still cost your dad about 15 bucks.
Nah, it will cost dad some bail money since he shoplifted the deckplate from the marine store. :lmao:
 

·
Registered
Joined
·
324 Posts
its probably emissions related. you will probably have to replace the catalytic converter, soon it will cause the first O2 to foul up and cause a CEL.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #13
Thanks for all the responses so far. I did a preliminary thread search before i posted but only realized after posting that i was using the wrong terms. Sorry for the redundancy. I'm going to spend tomorrow going through the fluids, filters, maf, throttle body, plugs, and check the compression. Hopefully this doesn't turn out to be a lemon.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #14 (Edited)
So I've changed the oil, the air filter, the fuel filter, cleaned the MAF and the throttle body, and replaced the spark plugs. I also checked all the brakes and driveline, everything spins freely. Greased the U-joints just to be sure. There has been very little improvement in gas mileage. The spark plugs didn't look too bad except for one that was a bit oily. I did a compression check while changing the plugs and most cylinders were around 170-180 psi with one at 190 and one at 165 (the oily plug one). The truck passed smog no problem and the exhaust pipe isn't black on the tip so I don't think the oxygen sensors or converter are bad. I'm kinda clueless at this point. Should I run some seafoam through the intake and see if anything improves? Replace fuel injectors?

One extra bit of info, the tires are 31 inch with a somewhat aggressive looking tread. Would switching back to the stock size and some more road friendly tires help substantially?

Thanks for dealing with my stupidity so far!

Craig
 

·
Registered
Joined
·
1,502 Posts
Figure out what gears you have. 31's should be fine though.
What type of plugs did you use? Should be the NKG's or Denso's from the dealer. Check your ignition system output voltage??? Or is the 3.4L coil packs on the plugs? Check if your cat is plugged, and clean & test your upstream O2 sensor. The TECH section has a write-up. Good luck! Also are you buying that ethanol crappy gas? Try a new flavor station.
 

·
Registered
Joined
·
2,030 Posts
Ok here's some off the wall one's to think about. Our your hubs manual? Insure not engaged. Make sure you not wheeling with 4 wheel engaged? Proper air pressure in the tires? Exhaust system? Check and see if there are any old codes in the computer? I get 17 combined. Just did the deckplate mod yeasterday. Fill the tank today. Will keep a close eye on mpg
 

·
Registered
Joined
·
324 Posts
it might be a stuck fuel injector, i had one on my grand prix stick open on me. it ran fine when accelerating but when cruising along it sputtered a bit.
 

·
Ban Count: 12
Joined
·
1,815 Posts
Muddin taco2131 said:
btw i would do the deckplate mod...afterall its FREE
He's got bad enough gas mileage as it is. :rolleyes:

The truck probably came stock with 28" tires and should be regeared for the 31's. :p Although the gas mileage wouldn't go down THAT much... Maybe it is pilot error? Maybe he just can't keep the foot off the skinny pedal? Maybe he isn't efficient with the gas + clutch?
 

·
Registered
Joined
·
60 Posts
check the o2 sensors you can even try to clean them up i also would do a pcv valve, check the things that are cheap first and things you can do yourself.
 

·
Registered
Joined
·
71 Posts
Are you taking into account that your odometer is registering fewer miles than actually traveled due to the larger tires? Unless it has been regeared or recalibrated? Check the odometer against some mile markers and see how acute it is.
 
1 - 20 of 22 Posts
Top