TTORA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 1987 4runner 22rte 4x4 automatic fuel injected. I recently had truck at a mechanic for over 6 months and I was told he could not find the problem with my truck. When i got the truck back it was very rough on idle and wanted to die I had to keep my foot on brake and use the throttle to keep it going. Now I have had the truck for two days and with a screw driver and only a adjustable pliers. I was able to make the truck idle just fine. The issue I have is as soon as I put it in gear it has a hard time idling and the more throttle the worse it gets.( original issue when I gave to mechanic) Very rough shake and almost sounds like a carb motor bogging out and very slow moving. I drove it home and it was very rough.(only option) when mechanic doesn't want to work on it any more. Wants to backfire, shake, and gutless uphill on drive way.

Things replaced:
Maf. Unit
Spark plugs & wires
Dust. Cap
Tps.
Newer turbo( ran prior to issue on motor)getting 10 pounds of boost seems to work great
New head gasket
New injectors from yota1 performance


Things I have worked on:
New ecm. Computer
Perfect pressure on cylinders
Timming is set
Tps is set
Adjusted idle screw
Checked for vacuum hose disconnected or loose.(sprayed carb clean around areas after to double check)
Blocked egr. To make sure it was okay
Unplugged cold start to see if anything changed.(nadda)
Cleaned throttle body
Valves have all been adjusted and rechecked twice hot and cold.

Also it is straight pipe no cat. If that makes a difference.

I am no mechanic at any means so any ideas would be appreciated. I am sure it's something small that is being overlooked. I have had this truck for many years built it from ground up with only a shell and a block. And really need it to be running again.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Add a bit more to it I found exhaust had made contact with shift linkage after fixing that and made sure the shifter was aligned correctly it seems to have fixed some issues. It's a bit rough running but now driveable.
 
1 - 3 of 3 Posts
Top