TTORA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
253 Posts
Discussion Starter #1
I'm looking for some idea's of what you guys think could be causing me to lose power steering sometimes while on the trail. I will lose it completely after wheeling hard and then it will return like 2 hours later. At first I thought it was due to a overheating PS fluid so I installed a transcooler and filled with royal purple ATF but no change in behavior. The fluid is alot cooler now though.

On the street I have no issues but it does seem to appear when I trying to turn the wheel against a rock. Guessing it only fails when forced to work hard then is gone for the rest of the trip till I'm back to no hard turning. I do feel little popping when turning the steering from middle to either side after driving straight for abit. Suspecting the rack is starting to fail on me but just want some opinions before I drop 400 dollars on a lifewarranty:D rack from autozone. The person in there is afraid of me since I've bought only parts with lifetime warranty from them and she knows me.
 

·
Registered
Joined
·
773 Posts
Probably a stupid question but have you checked the belt tension?

If it's not the belt then the pump could be getting ready to let go. Have you checked the rack for any play?
 

·
Registered
Joined
·
253 Posts
Discussion Starter #3
The belt has the proper tension plus the steering wouldnt just be going out when off-roading. I wonder if the little popping I feel has something to do with it
 
1 - 3 of 3 Posts
Top