TTORA Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Well just got my truck running after putting in an engine from my rolled 99' into a 01' and had to share my excitement. This has been the most in depth repair I've done by far. I had to repin a couple ECU and junction connectors to match up the wiring. Just when my hopes of getting it started from the wiring harness differences were getting low, I noticed a wiring change from the EFI relay no longer had power. Jumpered a couple pins and it started right up. After 3 years of sitting! It still runs rough, have a few sensors to get wired in still, but hopefully the rest will go well. Once I finish, I'll be posting some leftover parts from the 99'. Mostly just tan interior stuff, as I'll probably make the bed a trailer.The paint matches the new truck. If I transfer the TM 6in lift, I'll also have some 01 suspsension parts.
 

·
Retired
Joined
·
4,641 Posts
Well just got my truck running after putting in an engine from my rolled 99' into a 01' and had to share my excitement. This has been the most in depth repair I've done by far. I had to repin a couple ECU and junction connectors to match up the wiring. Just when my hopes of getting it started from the wiring harness differences were getting low, I noticed a wiring change from the EFI relay no longer had power. Jumpered a couple pins and it started right up. After 3 years of sitting!
Impressive! Good work.
 

·
Registered
Joined
·
8,499 Posts
awesome great job!

just out of curiosity though, what happend to the engine of the 01?
 
1 - 5 of 5 Posts
Top