TTORA Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
alright so heres the deal i got my truck really muddy last weekend and clogged the radiator full of mud so after it got really hot i pressure washed all the shit out of there and it ran at normal temp. the problem is though that whenever i get my truck running for a while it still sounds like its running hot and it gets terribly loud. any ideas on what it could be? any help is appreciated thanks ya'll in advance
 

·
Registered
Joined
·
2,030 Posts
You over temp'ed your rig. Chances are you already harmed the engine. Would recommend a computer engine check, compresion check and brain fratting?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #3
well if the compression was messed up it would be noticable. it runs like it normally does still got normal pick up and everything it is just loud
 

·
Registered
Joined
·
104 Posts
Discussion Starter #5
its almost like if my intake were clogged and trying to pull a bunch of air in and its coming from the drivers side so i don't know what it could be
 

·
Registered
Joined
·
162 Posts
You checked the air box and air filter I am assuming?
 

·
Registered
Joined
·
395 Posts
I'd say you've knocked something on the intake system loose. Check all connections and the air filter too. I've had mine so wet that it sucked it up the tube.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #8
yes i checked the intake and everything put a new air filter in. checked the motor with the hood open and the engine running everything seems fine. its weird because it only does it sometimes its not like something constant that happens everytime i run my truck so thats why i think its weird. i dont know if you will know what i'm talking about but it sounds like my truck is running on about a 100 degree day but its running at normal temp and everything. thanks for everyones help so far
 

·
Registered
Joined
·
104 Posts
Discussion Starter #10
i'm going to try and wash out the radiator again tomorrow see if that does anything. its doing it on and off again now it will howl for a little bit then when i slow down and get on it again it quits its weird
 
1 - 10 of 10 Posts
Top