TTORA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Ok, I have done ALOT!!! Of work since the purchase of my 87 4x4
Reg cab 22re... Tps,injectors,timing chain,guides, water pump,oil pump,temp sensor,belts,hoses,o2 sensor,rebuilt front end,new front diff,unjoints,trans rebuild,transfer case resealed,clutch,flywheel,pressure plate,slave,master,booster,proportioning valve,calipers,pads,brake lines,plugs,wires,cap,rotor,exhaust gaskets,starter,alternator,battery..I know there is more to the list... I've owned for 8 months now..my issues are....it runs rich and has a cold "hard start" so i spelled fuel in intake when it would sit a bit, so I put new injectors in it... It started great for a while after that... Well 2 weeks ago it started the hard cold start crap again...
And has ran rich since I got it...I have been. Tech at several dealerships and spent 6 years at a Vw dealership... I'm not an idiot but this thing is whooping my ass! I need someone who knows these trucks! PLEASE!!
Text me 512-818-2931 I'm in Georgetown
 

·
STITCH - Come and Take it!
Joined
·
9,051 Posts
No idea...sorry. Kinda surprised no one replied so far.
 

·
Registered
Joined
·
309 Posts
I just went through this same thing but with a 3.0. I got tired of years of trouble and bit the bullet and dropped it at a Round Rock Toyota. They fought hard with it for a couple months but it seems to be all better now. I wish I could give you better advice. In the end, it is easier to list what didn't get replaced than what did as far as sensors go.
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
7 Participants
98 Taco
TTORA Forum
TTORA forum is the best Toyota off-road club around. We are nation wide with chapters in most states. Come in and discuss Tacoma, 4Runner, Highlander, & TRD models.
Full Forum Listing
Top