TTORA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi all!! I just installed my Marlin trans.,flywheel,and clutch kit about 300 miles ago & all seems to be working great. My only question is why do I keep smelling gear oil in the cab?? Any thoughts?? Doe's it just build up pressure & vent upwards into the cab through the shifters?? It seems to waft up when I get on it a little, otherwise, I don't notice it. Seems strange only because there is no fluid leaking anywhere that I can see. I just figured maybe someone may have had the same problem....any help would be great. Thanks!!
 

·
Registered
Joined
·
1,329 Posts
not sure which trannies do it, but i know that some of them do vent through the shifter
 

·
Registered
Joined
·
978 Posts
i had the same issue after changing my xfer case oil. ....not sure why, but it wouldn't go away and i couldn't find anything wrong with my tranny or xfer case.

i solved the problem by rerouting the breather tube towards the back of the truck.
 

·
Premium Member
Joined
·
11,173 Posts
possible cause is a clogged transfer or tranny breather. I would also suspect that you might have over filled things a bit as well.

Try taking the breathers off and blowing them out with compressed air or just replacing them. (not expensive)
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
I don't remember messin with any breather tubes during the install?? Did I miss somethin?? The only tube I saw was a small 1/4" size tube that was only about 3" long & it went to & from the top of the tranny, to the right of the shifter. I added fluid until it just started to drip out, on both the tranny & T-case. I had to seperate the T case from the old tranny & there was 1/4 teaspoon gear oil in between, but the main seal on the tranny didn't look too bad, maybe I should have changed it?? Where else should I have seen vent tubes??
 
1 - 5 of 5 Posts
Top