TTORA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,078 Posts
Discussion Starter #1
did some reading on another post about oil filters and the article pretty much said that fram filters suck :soapbox: , turns out i've been using these filters since my first tacoma. bought a mobil1 oil filter and was wondering what oil filters you guys use and the word on mobil1 filters...thinking of switching to amsoil soon also. thanks
 

·
Registered
Joined
·
2,478 Posts
I dunno about the tacomas.... I have used 5 of the fram filters so far. My truck seems to be fine. My chevy trucks?? Both of them?? 200,000 miles on a big block, no oil issues. My race truck?? Only issue is breaking the cheesy remote filter/ cooler mount. Fram filters have been ok so far. We cut them open pretty regularly, to see what they catch. Also, we have 2 big magnets in the oil pans. We see the same thing in both places. Silt, after a while. The filters definitely do their job. I pre oil them before installation, and run 'em into the ground. I have never seen one implode or fail in it's normal life, even with lifters and rockers coming apart at high rpm.
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter #3
rojodiablo said:
I dunno about the tacomas.... I have used 5 of the fram filters so far. My truck seems to be fine. My chevy trucks?? Both of them?? 200,000 miles on a big block, no oil issues. My race truck?? Only issue is breaking the cheesy remote filter/ cooler mount. Fram filters have been ok so far. We cut them open pretty regularly, to see what they catch. Also, we have 2 big magnets in the oil pans. We see the same thing in both places. Silt, after a while. The filters definitely do their job. I pre oil them before installation, and run 'em into the ground. I have never seen one implode or fail in it's normal life, even with lifters and rockers coming apart at high rpm.
my family has been using fram from quite some time now with nothing but success also. what i'm worried about is switching to synthetic oil and having that filter on for > 6k miles...usually how long do you run the filters on your vehicles, synthetic oil?
 

·
Registered
Joined
·
2,478 Posts
On my work truck, 454 chevy, I have a deep sump oil pan- 7qts. I change oil every 5k or so. No problems. My oil is dark, but 200k will do that. Stuff just gets by the rings when they are getting up there. But, there is not any noticeable large metal grit, either on the pan magnet or in the filter itself. But when my rockers went on my race truck, it got small parts up into the oil pump, and the filter did show lots of chunks. But it didn't rip appart or anything like that. So, seems ok to me.
 

·
Registered
Joined
·
169 Posts
I posted about this last week and everyone said that Frams suck, and I even got a link to some study this guy did http://www.scuderiaciriani.com/rx7/oil_filter_study/ he said frams were bad because they have cardboard end caps and that he had personally had one fail. That is why I went with the Mobil 1, aside from the fact that I have always used Mobil 1 Oil and they are known for making a quality product.
 

·
Registered
Joined
·
2,478 Posts
Well, I guess anything can happen. I dunno... I run a hi pressure oil pump, it cranks out 80 or so psi, and the filters have never come apart. I have seen lots of fuel filters get mangled when lots of junk gets in them, and the pump is still wailing away, but that is Typical for fuel injected stuff, especially diesels. I personally have never had one crap out on me. And, I believe it was consumer reports did a big write up on faulty filters, and showed some companies stuffing rags down in the cans instead of filter elements!!! Fram was not one of them. They also make filters for several other companies, and package them with a different name. Like Toyota makes Lexus. I don't think their long standing rep is in any danger, nor is the motor they are sitting under.
 
1 - 6 of 6 Posts
Top