TTORA Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Was wheelin' last night when all my lights & accessory's started flashing on and off? So ... decided to haul butt back to the house when sparks started flying from under the hood???? Jumped out with the mag light and took a look. While I was wheelin the side screw (GM) style connector on the battery over heated and melted completely out of side of the battery??? Damn connection for my accessories must wiggled loose while I was bouncing around. Either way, battery still works fine?:lmao:
 

·
Registered
Joined
·
238 Posts
Is that a question or a statement?
I think its a question. though it sounds rhetorical. Your battery should be fine. Only when you hook it all up will you truly know.
 

·
Registered
Joined
·
779 Posts
is there such thing as a rhetorical statement? if so i think that's what it was... batt should be ok... good luck
 

·
Registered
Joined
·
153 Posts
I just recently saw one come in as a core that had the same exact problem...interesting.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
Yea, well when I took it back to AutoZone... They wanted to pro-rate it where I would have to pay $117.00 for another, because it was two days outside of the year warranty???:eek:
 

·
Registered
Joined
·
153 Posts
That's optima's deal, not AZ's. An optima only has one year free replacement? That seems extremely odd for the price you pay...seems like the pro rating drops off really fast too.
 

·
Registered
Joined
·
281 Posts
Optimas have a three year free replacement warranty. At least mine did. I have a red top. It was just over a year old and I started having problems with it not have enough amps to start my truck. Took it back to where I purchased it and the tech tested it and said it was bad. He told me I have a three year free replacement warranty. He put in a new battery and I was on the road again. :2cents:
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #9 ·
Well I spent $200.00 on the big dual post yellow top.... Think I'm going to e-mail optima????
 

·
Registered
Joined
·
84 Posts
I had a redtop on my Tacoma like 9 years ago, it was great.

So I bought one last year for my Tahoe, after 2 weeks my Tahoe started going dead in the middle of driving. Couldn't figure out what the issue was. Finally it wouldn't turn on at all, and I had it towed to the shop.

Turned out the Optima was a dud from the start. :( My confidence for the Optima fell a little after that. Never had a dud normal battery.
 
1 - 10 of 10 Posts
Top