TTORA Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I feel as though my truck is loosing power. When i put it in 2nd gear it seems to be extremely slow in the first half of the gear. Could this be me needing to change my timing belt? I am also looking to add power, supercharger, intake? Any suggestions would be appreciated
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
98 tacoma extended cab
sr5 v6
manuel tranny
148000 miles
never had any major maintaince done to it
 

·
Registered
Joined
·
15,034 Posts
Will probably get better response in the Early Tacoma folder.

Isn't the timing belt due at 90k miles? :eek:

I would do Seafoam (search "seafoam") and then replace the plugs and the O2 sensor (front)
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
i did the seafoam stuff and changed my spark plugs and wires. Anyone got any other suggestions?
 

·
Registered
Joined
·
533 Posts
Everything above and:

Replace fuel filter and air filter, keep using an injector cleaner and an intake cleaner at every oil change. Did you gap the plugs to .043?
 

·
Registered
Joined
·
15,034 Posts
Well, to check the belt, you'll have to pull everything off - may as well replace it by the time you get in there.

I meant to check the ignition timing, though - however many degrees before Top Dead Center
 
1 - 10 of 10 Posts
About this Discussion
9 Replies
4 Participants
RedRunnertc
TTORA Forum
TTORA forum is the best Toyota off-road club around. We are nation wide with chapters in most states. Come in and discuss Tacoma, 4Runner, Highlander, & TRD models.
Full Forum Listing
Top