TTORA Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
460 Posts
Discussion Starter #1
I did the leaf pack rebuild. Used 26k leaf for main, and leafs from a 92k pack as the bottom two add ons. Originally everything looked ok, after 250 miles or so this is how things look. Its been about 1k since the rebuild now and has not gotten any better or worse. I am afraid it could get worse any day. Any Ideas on how I can resolve this issue??


 

·
Registered
Joined
·
1,337 Posts
Its hard to tell, but I think you may have 1 leaf backwards. You should have the short part of the leaf going forward, and the longer part at the back towards the rear shackle. There is a slightly different curve to the front(short) part of the leaves as to the back(long) part of your leaves.

*This is just an educated guess*
 

·
Registered
Joined
·
2,538 Posts
if built correctly. axle wrap is the most common cause of bent leafs. 1" lift shackle, shackle 2" taller shouldn't cause this, unless your leafs are negitive arched.
 

·
Registered
Joined
·
1,114 Posts
If it was me I would go stuff/droop it till it quits and see what it looks like there.
If nothing was out of whack at the extremes I wouldn't sweat it...
but thats me and I don't even know if I know what I'm talking about or not.
 

·
Registered
Joined
·
460 Posts
Discussion Starter #8
Its nearly impossible they are backwards, the leafs are not same distance from eye-to-pin-to-eye one the rear is longer than the front. we cut the leafs by holding them up to the 26k (now main) pack and trimming them the same distance each end, not same distance form eye, so if you were to spin the leafs around they wouldn't fit in the pack, one end would be as long as the leaf above it (from pin to end of leaf) and the other end over 4" shorter...........
 

·
Registered
Joined
·
460 Posts
Discussion Starter #10
idk if 99 springs are differnt from 04 model springs? if so that might be an issue, the main pack has 26k from a single cab 04, the added leafs have 95k on them from a 99 ext cab.
 

·
Registered
Joined
·
1,754 Posts
RENEGADE76254 said:
i cut the springs not quite 2" shorter than the one above it, is it possible i cut them too long?
It doesn't look like it from the pic. How hard have you wheeled them? It may be that you bent the uppers, or they were bent to start with.
 

·
Registered
Joined
·
460 Posts
Discussion Starter #14
joel said:
It doesn't look like it from the pic. How hard have you wheeled them? It may be that you bent the uppers, or they were bent to start with.
no real wheeling trips on these since the rebuild, just hunting trips and pulling folks out of the mud.
 
1 - 14 of 14 Posts
Top