TTORA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
Yesterday my speedometer just stoped working, all teh other guages still work. Today the check engine light came on. WTF i think...can it be related.
Need all the help i can get before I take it appart.
Thanks
Roger
 

·
Premium Member
Joined
·
362 Posts
rojo22 said:
Yesterday my speedometer just stoped working, all teh other guages still work. Today the check engine light came on. WTF i think...can it be related.
Need all the help i can get before I take it appart.
Thanks
Roger
take it somewhere and get the codes checked. If you have a bad vehicle speed sensor it will kill the speedo and turn on the check engine light
 

·
Registered
Joined
·
565 Posts
The CEL came on b/c of the speedo issue.
What year is your truck? 95-97(I think) is a cable speedo, 98-curent is an electronic speedo.
I have had two issues with my 1996, 1st the gears stripped out where the cable plugs into the transfer case. and the 2d was the cable broke a few years later. Both produced a CEL until I fixed the problem.

If yo have an electronic speedo, someone can probably tell you how to use a VOM to trace the problem down.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #5
Mine is a 97. I did notice that when it was cold the speedo was king of noisy. I will have to take it apart. Hopefully nothing major
 

·
Registered
Joined
·
565 Posts
rojo22 said:
Mine is a 97. I did notice that when it was cold the speedo was king of noisy. I will have to take it apart. Hopefully nothing major
Ahh the infamous squeeking speedo cable :). A new one will run you $60-80 and an hour or so to install.

You may want to check the area where the cable plugs into the transfercase, you may be lucky and it's only unscrewed....
 
1 - 6 of 6 Posts
Top