TTORA Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello guys, it's been awhile since I've been here. Been busy with my twins kids. Anyways I have a problem with a 2000 Prerunner V6 tacoma, was wondering if anyone has any ideas:

scanned codes and found that bank1 sensor1 was running lean:
cleaned MAS
cleaned IAC
Cleaned PCV
checked for vaccum leaks
No good code came back as:
CEL code of po171
truck has hard time starting up when cold, will back fire if tring to rev to keep idle. So I checked IAC again and looks good, cleaned it out agin. Then I changed:
changed 1st O2 sensor
threw another po171 with another po171
changed MAS
all codes cleared and no codes present.
Now truck starts up fine when cold.
New problem that I cannot solve:
Will start up fine when cold (like in the morning)
Once I get to work and park the truck (about 12 miles away) and come back out a few hours later like for lunch, it starts up and idles but when shifted into gear it wont go as though there is no gas, and at times it feels like it is running on 3 cylinders casue it shakes like crazy and really lacks power. No CEL, but there is a little indication of misfire and back fire that I can hear in the intake. Another thing is that sometimes it wont happen at the start, but later on down the road a few minutes later while I am driving, the truck just looses power, speed decreases and if I try to accelerate by pressing on the gas, nothing, it will coast down to about 5 mph then just kick back. I notice that the motor is still on, but it feels like it is off, kinda like downshifting to a lower gear to slow down. It is really buggin cause it doesn't do it all the time, maybe 2-3 times out of the week. Starting to scare me cause I was on the freeway and it did it at about 70mph, it just decreased speed and I coundn't do anything but throw on hazards and cost to the shoulder until I hit about 5-10mph then kick on agian. really wierd. ANy insight would be helpful.
truck has 88000 miles
timing belt done at 65000
replaced waterpump
regular tune up
I thought it might be the coils, or maybe a fuel pump, or fuel filter, what do you guys think?
Dealers cant troubleshoot what they can see happen so they are useless.
Thanks in advance.
RV
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
stumble

Just to add, I now notice a little surging when cruising at high and low speeds as well as more surging when going uphills. hope anyone can help out. Thanks
 

·
Registered
Joined
·
147 Posts
everyone is going to tell you to change the fuel filter first and then probably check the resistance on your ignition coils and then your igniter... sorry I can't be much help b/c I sold my car when the mechanics couldn't figure it out. Mine started off as random, but in a couple of month it became consistent.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
stumbling

Thanks for the reply. So did yours do the same thing or similar? Cause mine is random right now. I will check/change the fuel filter this week and see. Can you give me more detail on checking the ignitor, coils, and others. Appreciate it.
Ricky
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
stumbling still

Well just changed th fuel filter and still have issues.
truck just falls falt on it;s face and if gas pedalis pressed, youcan hear backfire from intake. truck feels like it surges while cruising on freeway. Any help please or truck will be up for sale soon. Thanks.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Fixed

Well, after many headaches, I figured it out. It was a few bad MAS/MAF sensor. Switched out 2 more after the new one and discovered that they were bad, or calibrated wrong according to the dealership. I had to try 2 more to determine. First one was surging, second was stumbling, third was hard to start, ansd final one was good. Well I just thought I'd share this with everyone.. Just casue it is new doesn't mean it is good!
 

·
Registered
Joined
·
5,490 Posts

·
Registered
Joined
·
147 Posts
dang, should of kept the truck....I swapped w/ my buddies MAF, whose car was fine, but it was the same result. way to be persistent
 
1 - 9 of 9 Posts
Top