TTORA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
I havent driven my truck much at all in the past 3 or 4 mos. The other day, I started it up, and when I let the clutch out to let it sit and idle/warm up, the truck moved forward slightly......

So I let the clutch in and out repeatedly while sitting on flat ground, in neutral, and each time I let out the clutch, I could feel it move slightly forward each time....

Its always made (what I thought) was a weird noise while idling with the clutch out, since I've had it....Even used to make kind of a squeeking noise....I tried to get the dealer to check it out the first week I had it, but the tech told me it was normal...(Go figure....)

Any ideas on whether it might be the clutch, throw out bearing, or maybe slave cylinder out of adjustment?
Maybe my clutch pedal?....

Thanx!
 

·
Premium Member
Joined
·
191 Posts
Maybe I'm missing something here... You let the clutch out while the transmission was in Neutral and it moves forward? I don't see how this could be a clutch issue.

As for the noise, the Taco's I've been around have been fairly quite while idling in Neutral. But when my throw-out bearing went out (at 180K miles mind you) the noise I had was when the pedal was pressed down and was much quieter when released.

edit: Good call on the gear oil, I forgot about that as I switched to Synthetics years ago.
 

·
Registered
Joined
·
358 Posts
My guess (in terms of the truck moving forward) was maybe due to the gear oil having sat so long. Maybe it was acting as a "coupling" device to get things moving. I experienced this in a previous 4x4 (Suzuki) on a regular basis on cold mornings and there were no problems.
 

·
Registered
Joined
·
34 Posts
Sounds to me like your clutch is a little out of adjustment. If the release travel of the clutch pedal isn't far enough to fully disengage the disc from the flywheel, it will make a squeeling noise and cause the truck to creep slightly. Throw out bearings usually make a noise when the clutch is depressed.

Another possibilty is you have a broken spring or two on your pressure plate.
 
1 - 5 of 5 Posts
Top