TTORA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Another reason to move south!
But I have to say, i'm not very impressed with the fact that in about 8 years of driving around NE Ohio this mounting perch disintegrated to nothing and tore away from the frame. (I sure aint going to let any of my Ford or Chevy guys let me know i'll be welding new sway brackets into my '99 PreRunner. I'll never hear the end of it.) "Fortunately" the dealer thinks he can order a replacement mount that can be welded in for about 25 bucks (parts cost).:saw: :welder:

 

Attachments

·
Administrator
95.5 Tacoma
Joined
·
18,523 Posts
The A/C evaporator drip line is also known to drip right there. That would sure speed the rust process right along.
 

·
Registered
Joined
·
74 Posts
I herd a clanking noise yesterday so i put it on a lift today and I got the same thing. Plus in the rear right where the front of the leaf attatches to the frame, looks like swiss cheese. Not sure what I'm gonna do yet.
 

·
Registered
Joined
·
2,364 Posts
Damn, those metal eating termites are huge in Ohio! That damage was all caused by rust? The mount wasn't cracked first, then rusted through? Anyone with a welder can fix that one for you. Have you checked the other side for the same damage?
 

·
Registered
Joined
·
65 Posts
The A/C evaporator drip line is also known to drip right there. That would sure speed the rust process right along.
Exactly. I solved that problem using a length of rubber tubing from where the condensate comes out and routed it to the passenger side wheel well. I just used wires to hold the tubing in place.
 
1 - 5 of 5 Posts
Top