TTORA Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,472 Posts
Discussion Starter #1
I was cleaning out my air box and my throttle body today when I noticed that my throttle body opening is only open by about 20 degrees when it should be about 45 degree when the accelerator cable is pulled all the way down. Its not the adjustment of the cable. Even when you move the throttle body mechanism by hand its only open at about 20 degrees. Oh well, I'm glad discovered it. Probably one of the reasons why my mpg has been bad lately. Going in for warranty first thing tomorrow morning. I hope dealers dont screw it up. I didnt expect this to my happend to my 1 year old truck.


03 TRD 4x4 SC URD
 

·
Registered
Joined
·
4,294 Posts
good luck with that...hopefully the techs at your dealership arent as incompetent as they are at mine
 

·
Registered
Joined
·
1,472 Posts
Discussion Starter #3
OKay check it out guys. After some researching and having a mechanic check out my throttle body, throttle body is fine. It fully open onces the truck is started. Although the TRD SC instruction tells to you check the to make sure the throttle is fully open when you press down the acclerator all way down pulling on the cable, the throttle body on the 02s and up are completely different. The newer TB has some sort of electronic throttle device with one cable and the old TB has two cable and is completely mecanical. The cable is there is a fail safe just incase the electronic on the throttle body fails the cable pulls on TB just enough to get you home.

BTW: I guess TRD came out with a supplement instructions for newer style TB bodies recently...about a year after my SC has been installed.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
Super Doody
TTORA Forum
TTORA forum is the best Toyota off-road club around. We are nation wide with chapters in most states. Come in and discuss Tacoma, 4Runner, Highlander, & TRD models.
Full Forum Listing
Top